ELR Home   Create recipe   Resource page   My recipes/favorites

Skyhook Down! Help!


#1

So my skyhook is not working properly.
Yes i charge from usb and yes i know i shouldn’t but it has worked fine for months with no issue, until today i popped my batteries out and when i put them back in the screen will no longer turn on. Button pushes do not help any, cant see menus but im pretty sure it isnt in stealth mode. Connecting to usb on computer with batteries out and firing allows the computer to detect a usb device but doesnt seem to do anything jist hear the ding of it being plugged in, nothing more. The screen does not turn on even after minutes of holding it plugged in to pc. Im at a loss here guys… Any idea how to idk maybe rewrite the original firmware on it or some kind of factory reset or something? Or perhaps the lcd is just toast?
It still locks and unlocks with 5 clicks, and fires, but no display so no idea how to navigate thru it not even a charge indicator while plugged in


#3

No it just didnt work suddenly.


#4

My nephew’s Skyhook split itself apart by the tank and the mod?! Leakage dissolved the glue I think?!


#5

Still fires, seems to adjust wattage/tc (not sure which since i cant see display lol), 5 clicks lock/unlock
Seems my display just crapped out… Ive tried reflashing it, though successful on computer end, still no display. Im just at a loss here guys… I just hope its not a burnt out lcd cuz i cant afford a new mod… This one isnt that old it should work -_-


#6

Really regret ever getting a Smok… Never had any Smok mod or tank that didnt give me trouble… Think id learn my lesson by now :confused:


#8

It has a couple tiny toque screws on top but not sure beyond that, id have to youtube a teardown guide to be sure.


#9

sorry for hearing this… though Alien 220 and al85 by Smok had problems with dead screens, bricks etc… in the past unfortunately :frowning:
smok also had made an article as far i remember also that stated users to prevent getting batteries out while the mod was ON and this could break cause problems to the device… though as far i know some people solved (about al85 and alien 220) by upgrading/rewritting firmware on the device… you could try this…

https://www.smoktech.com/faq/16

can’t check if there is an upgrade or the original firmware in smok’s site… seems that for getting a product verification to get support…

https://www.smoktech.com/support


#10

I have already erased and reflashed it with firmware, no change.


#11

i can’t think of any other way than opening the device and checking for loose connections but i am sure that it wont help either… in the recent past smok had problems like this as i said with alien 220 and al85 :frowning: you can check this with a fast search in google… at your place i would start thinking of buying a new mod unfortunately :confused:
sorry :frowning:


#12

Yes im aware, hence me saying my lcd may just be burnt out lol i have already cleaned it up, and erased and reloaded firmware, to no avail. Guess i just have to learn the menu by # of clicks and long presses till i can afford a new mod. And next one will NOT be Smok. So sick of the nonstop issues with their products.


#13

Sounds to me like it uses the exact same chipset as the alien mods by Smok that are going DOA.

I’d have to see inside to be 100%, but it sounds like a safe bet though. =(

Sorry for your bad luck.


#14

I can already tell you with 99.9% certainty that there is no loose connection per se. It’s a chipset/firmware issue.


#15

You could try a factory reset no idea if it will work or not

Put your batteries in but don’t close the battery door hold down the up and down buttons and close the battery door you may or may not see a reset to factory settings screen after a few seconds.

The other way of doing it is to take the batteries out and hold down the up and down buttons and plug in to a computer or charger.

You may need more than two hands to do it and it may or may not work - it does sound like a hardware issue rather than a software issue in which case it will do nothing to help.

This is what it looks like on the alien (the skyhook has the same chipset I believe)


#16

I did manage to successfully reload firmware (alien firmware is identical to skyhooks) but still no display. I think the lcd just fried. Basically, screw Smok. Next chance i get to buy a new mod, itll likely be a evic dual kit… They are priced fair and function well and the vtwo i had was one of my favorite mods so hopefully the dual will live up to that. No clue when ill have money to get one tho so trying to mess with this with no display is almost more frustrating than just dealing with my nic fits without it anyway


#17

If you can get it apart, batteries out, hose the circuit board down in 90% isopropyl and let dry. I’ve resurrected a few boards from overdripping. The only one that hasn’t worked on is a vt133 I was charging via USB. Coincidence? No idea.


#18

mine was usb charging… it fired still, lcd was just fried…
it has since been junked.

I am just using a RX Mini now with my old Serpent Mini 25mm, and The Troll RDA


#19

Mines leaks if left standing unused?
Have no idea where the leak originates or how to prevent?


#20

I wasn’t a Smok fanboy but I never had any real problems with their stuff until I got the Skyhook. I read some accounts where Smok support was telling people to watch the youtube videos to fix them. They have leaking problems and shorting and board problems.

Mine has leaked since day one. I watched all the videos and tore it apart as best I could and filled the entire upper area with silicone. It still leaks around the little view window, gets inside the case and makes it into the battery compartment.

A local store was selling Skyhooks, the manager used one for about a week and had so many problems with the board and customers returning them with problems, he sent the rest back to the distributor.

Not a Skyhook issue, but about a month ago I was at another store and watched an employee trash his TFV12 trying to get it off a Procolor mod where the 510 broke and just spun. A few nights ago at a vape store, I watched the owner go through 5 brand new Smok coils, all defective. Doubt I will be buying anything Smok soon.