ELR Home   Create recipe   Resource page   My recipes/favorites

Wismec Reuleaux RX200 Not Firing


Nope I checked my center pin on the tank is protruding a good amount. Defiantly not enough to cause a short.


I Figured it out. Its the coil in the Herakles Plus. When I got home I threw it on my Ipv d3 and it read LOW RES and it was .09. So there is nothing wrong with my Reuleaux its just that the Herakles coils is fucked.


Glad the hear that, I like mine a lot and use it more than any mod I have


Hahaha me too! That why I was so concerned! :joy:


Mine has been rock solid, I only use it with titanium wire in TC mode. It is a little finicky when I take the tank off to re-fill and/or re-build but as long as I lower the temp before firing it and only chose new coil when I have actually re-built my coil then it works flawlessly for TC mode


Great to hear buddy.


Good deal, i used mine with SS TI without a problem. But to be honest. Its my secod in line mod. I use my wismec dna200. But i find the rx200 to be a great mod.


Yeah I just don’t have a need for the Dna200 because I won’t be able customize it with my mac. plus they both do almost the same thing! Thanks for the support and help guys!


Blasphemy! :slight_smile:

If you had one you would not be saying this. Also, you only need a PC for as long as it takes to set up the device. Perhaps @Big_Benny_MI could shed some light on using a Mac to work with the Evolv software. But truthfully these mods are not even in the same class…


Yeah I’ve seen a few comparisons and the Dna200 looks a hell of a lot nicer.


To me the differences are a matter of temperature control performance, reliability, stability and the ability to upload custom wire profiles with great accuracy.


Glad you got it working. Happening at work would make me panic. Have had problems at work it’s not fun. Last night my rx200 stopped firing in tc (rda with ss coils). Working in power mode. Installed aromamizer with ss coils…it worked in tc. This am rebuilt rda with ss coils.it worked. It was odd


Glad your up and running. It’s usually something simple. :stuck_out_tongue_winking_eye:


I’m sorry, but there is no comparison between the rx200 and the dna200. That’s like saying a Chevy is the same as a Lamborghini. I have both and use both. But you cant say they do the same thing, because they don’t. If you had a dna200 mod you wouldn’t say this.


yes, they do…i sell both. i use both. unless you like customizing error messages, or vaping while connected to a computer, they aren’t all that different.


The great thing about the DNA200 is profiling. You can have up to 8 different profiles for different coils. For those who like to make their own coils (like me), it’s not possible to compare them. I do like the RX but that is only due to having 3 batteries. Other than that, ist a standard TC device with ok settings. With ok, I mean just that ok, since there are alot of devices with better tc settings than the RX. But when it comes to tweakability, DNA200 is the best device so far I have used. You do not have to be linked all the time to use it, alas, you need to link it up to load new values into profiles.

The other great thing about the DNA200 is that, there are other metals out there to vape on, or different purity’s in the metals. With DNA200 you can do that. They are however working on an softwareupgrade on the RX to implement TCR ( or so I’v heard)


Most of us have already upgraded to version 3.0 which does give the Rx200 TCR capability. Perhaps the Dna200 version is a little better than the Rx200 but now that I can dial in TCR to perfection I am perfectly happy with the Rx200…


Hehe, I have not upgraded my Rx yet, but will do that now. Thanks for telling me. For some reason I have gotten used to do all me tweaking with the DNA200 and use the Rx only for simple tanks with standard premade standard coils.

Even upgraded my wismec Presa 75tc, not sure how I missed the upgradepossibility on the Rx.
Again, thank you very much for telling me :smiley:


Had trouble with my RX200 today. Wouldn’t read my TFV4. Put in my Delta, Velocity, PV…same thing. Check the 510 and the pin is not springing up and down. Checked the web and found that the TFV4 has a habit of wrecking the 510 connection on the RX200 as well as the Cuboid. Apparently, the materials used for the 510 are substandard and Wismec/Joyetech will not honor the warranty. From what I’ve read on Reddit, it actually voids the warranty. I was able to gently pry it up using a dental pick but it’s not springy. For now it’s working and the TFV will have to reside on an istick.
I don’t know if this issue affects the DNA version or not, but I’d be careful.


Might want to put an insulating spacer under the tank if you own one.