ELR Home   Create recipe   Resource page   My recipes/favorites

Wismec Reuleaux RX200 Not Firing


I have a friend on another forum that had the same problem. She had to return it. Apperantly there are some issues with it. message me an email address and I’ll send you an article she pasted into a message to me regarding wismec


I just got my RX 2/3 about 2 weeks ago and was using a cubis pro tank on it fine. Just bought a Uwell Crown V1 tank and now I keep getting atomizer low error message, and have changed the coil and still getting the error. Is there like a known problem with this? Is it the tank or the box?


I get this from time to time with mine as well. Got mine about 6 months ago and to fix it, for me, I simply pull the batteries out and put them back in and BLAMO, all is well in the world. When I first tried to reseach this issue I got nothing. Havent tried looking lately but the “pulling the batteries” thing has always worked for me.


My RX200 started doing that. At first it was erratic and eventually it was anything I put on it. Turned out to be the 510 connector. Replaced the connector with an upgraded Varitube version and good to go. Not the hardest thing to do, but far from the easiest. I also have the RX2/3 and the 510 connector on this one looks cheap too. Can’t understand why big companies like Eleaf, Joytech etc go so damn cheap in quality on the 510 when the cost of a better one is so cheap in price.


Hi theres a good chance you have no clue what im talking about but im going to try and ask seeming i have ran out of options. i just got the wismec rx2/3 brand new off amazon. it was working fine for the 15 minutes of using it. as soon as i took the tank off and put it on my old mod i used before i got the new wismec product. and now it keeps saying no atomizer found
its not the tank im sure of it. im not sure if the messaged popped up saying ‘NEW COIL’ ‘‘RIGHT’’…’ SAME COIL ‘‘LEFT’’ i must of just fired and go but then message pops up saying no atomizer i have tried every option out there and still know whats wrong… please help,. thanks


The 2/3 is a bit of a fussy one (the 510 isn’t great). Try disconnect the atty hit the fire button reconnect the atty. You can also try to update the firmware. Also make sure that the pin in the centre of the wismec 510 is not stuck (press it with a small screwdriver make sure it moves). I find that the 2/3 just plain doesn’t like some attys (hopefully not the case with yours)

I put the Nfe ArcticFox firmware on my 2/3 and it is 1000 times better than the wismec firmware.



Speaking of the 2/3, mine crapped out a few hours ago and is giving me the “check battery” indicator with 2 sets of fully charged batteries. Any idea what the solution might be?


Wismec are known for awesome soldering (NOT) - check this one


And me without a solder gun…


Take it apart and see if that is the issue it may just need a clean out of juice - if needed you can get an iron for a few bucks at the hardware store


Curse the rx200! My IPV5 crapped out the other day at work(lasted 1 year, even dropped it in a catch basin and was fully submerged in water for 8-10minutes) and “luckily” i had an Rx200 in my car. I “had” a Rampage RDA with 3 316L claptons in it. Sweet build and flavor. Decided the frikkin RX was shite when i got home as there was a huge delay upon firing like no joke 2full seconds… Unscrewed my Rampage put it on my alien. Atomizer check! Hrmm. Tightened screws, still nothing. Unscrewed the rda to find the stupid f#%#! RX 510 had unlodged my Rampages 510 insulator. Like wtf wismec fuck off with your unfloating shallow 510!