Alien 220 a version

Hi there :slight_smile: Last time when i used my mod i had problem with him. Mod was crazy and showed me crazy things, all of the menus, he changed watts to lowest. and he changed buttons, thats mean i cant use now +/- buttons for wattages, only lower button works, but when pressed he block the mod, when im using power button hes showing me power menus, and + button dont work at all, i tried to upgrade firmware but nothing changed, i tried to use hard reset, but it seems like i cant press yes. there is any solution for my problem? or its just chip fault and i cant do anything at all?

I tried to use both of 1.2.11 and 1.3.2 to upgrade firmware, but both didnt work.

Hope there is any solution for my problem :frowning:

1 Like

I hate to sound like a smartass but maybe get a different mod from another manufacturer. I have had numerous alien mods and it seems like they last less than 6 months for me. I tried to look at like this, I paid about $30 and that would be $5 a month which is still cheaper then a pack of stinkies. I had one I tried to do an update on and later found out it was bricked. I sent it back to where I bought it and they sent me a new one. It seems like a lot of people were having problems with them getting bricked. Best of luck :slight_smile:


Maybe you can get some useful info in this thread and if it’s too confusing you could drop @Sprkslfly a PM, he might have something to add that could help you.


Worked wonders on my alien! Our first two lasted about a year. Our new set had one malfunctioning one and it was a wire issue. They both are still working fine. It is kind of hit or miss with this mod. Hopefully you get it fixed!


You could try a hard reset


There’s an obvious language barrier in play here, but we’ll see if we can mutually overcome it! :wink:
Well done for being willing to try and speak another language though! Many are too afraid to try. (If you’ll tell your native language, perhaps we can find someone in the forum willing to translate, which might help make things easier for each side to understand?)

I’ll try and touch on a few things, though honestly, from the sounds of it, you have a situation that needs to be addressed by someone with technical ability in electronics.

  1. the display freaked out…

  2. the device reset itself at some point (evidenced by going to lowest power/wattage), OR the down button is “stuck” (making constant contact, which could conceivably throw the chip into chaos.)

I don’t understand what you mean by this: “and he changed buttons”
Did they operate reversed (+ made things go down, and - made things go up)?
Or did someone already disassemble the mod, and physically replace the buttons?

And worst of all there’s conflicting information:

But you just said “thats mean i cant use now +/- buttons” (which means NEITHER button works)…?

How could you even GET INTO the hard reset option without the + button working?

The way it stands though, regardless of the language barrier, and with the conflicting information… or possibly you are encountering circumstances that are frequently changing (and you’re describing each different set of events in a single thought). But there’s no way that some of the things you’ve described could be happening at the same time. So it’s a bit confusing.

Bottom line, I don’t believe there’s anything you can do. It needs to be looked at by a professional. They need to see EXACTLY what happens, and when, without confusion, to be able to make a proper assessment.

My personal opinion is: avoid Smok when it comes to mod choices.


I owned an ALien from preorder to last week no problems, but eh, I ended going with a smoant cylon. I didn’t do a firmware upgrade or anything like that but I guess I was lucky with equipment

You’re going to LOVE that (if you haven’t used it already). That’s all I can say for the moment. :wink:

yeah, I love it already, makes my aromamizer v1 look like a baby rdta but eh, 30mm base acceptance is one of the pros on why I got it.

it’s confusing to me, because, when mod is turned on and i’m trying to press upper button, he is disabled, he did nothing after press, usually he changed wattages.

When i tried to press lower button, he also changed wattages before, but now mod is blocked by click.

Same with fire button. Now when i’m trying to press he is showing menu with powers. This button dont activate coil now.

That’s what I mean when i’m saying about “changing buttons”. Now same buttons do diffrent things.

I can turn coil when i use lower button and fire button after unblock. Usually he’s blocked 24/7.

Well thats why im confused, because when mod is turned on, + button do nothing, when mod is off i can go into hard reset, but when screen is showing me question about hard reset i cant press “yes”.

Well, theoretically I can use it, but i tried many things. I reset my mod with firmware update and this didnt do anything. Except changing watts to 220.

(So its hard to smoke now because of taste :smiley: )

You’re right, I’m from Slavic areas, but I’m trying to write the best I can. I do not have much hope to fix it, but maybe someone who knows something more will give a crazy idea what to try ^^

Also i sent question about it to the smoktech support. We will see what they say, for sure i will give info when they answer.

Greetings, great to talk with you guys :smiley:


My gut instinct says you’ve likely got one of two things going on.

  1. Your firmware somehow got corrupted (buttons being “reassigned”). But this would be the first time I’ve ever heard of anything like this happening, especially in relation to a vaping device.

  2. You’ve possibly got a switch (or two) where the contacts have collapsed (either partially, or completely) and the constant/intermittent contact that is being made is throwing the chip into a state of confusion. (this scenario is far more likely in my opinion). In which case… A qualified tech needs to replace the switches.

The only other thing I could say that you might try, would be to see if you can flash the proper firmware to it, and see if that fixes anything.

Outside of that, I’d recommend replacing it, I ideally with a Smoant Cylon. :wink:

Best of luck, and welcome to ELR!