Any Smok Priv 220w users out there? needed!

So I have had this Smok Priv 220w since June, then today it started going a little crazy, I put 22 Ti coils in last night, worked great, no problems, then this morning it starts jumping to Watts mid pull, ok…fine, figured it was the coils, changed the top, no probelm, then it started telling me the ohms were too high in my Messes, I knew they weren’t, changed tops again, no problem, then it intermittently started telling me to either ‘check atomizer’ or that the ohms were too high again, then it told me to check atomizer on EVERY tank, so i took the cover off in case some liquid had got inside or something, a little was there but not much, I dried it out, wiped it down best I could, pulled an old dripper off the rack, worked fine for an hour, then started with the ‘ohms too high’ again…then proceeded to go through the exact same order of fault warnings again, and now it won’t work with any top at all, just says ‘check atomizer’.
to top this off I dusted off my old mechanical tube just to cover while I sorted this out, wouldn’t work, and I sold my old Vamo to a guy at work last week, so now I am down to my rx200 and that is it, 1 mod…1st world problems I know but, 1 mod…as for the Priv, it’s updated, I don’t know if I can send it back because I dropped it a couple of weeks ago which put a small ‘bend’ on the corner and I know they will blame that, it worked perfectly well after that up until today, so, has anyone out there ever heard of this kind of issue before??..I know it’s a long shot, but I’m a 1 mod man right now…desperate times…:fearful::cry:

Mild panic over, I think I fixed it, took it apart, air blew it out and had the hot air gun on it gently for a bit, I think some liquid had seeped in somewhere.
I thought it might be a long shot for help lol, but cheers anyways! :+1:


Sounds like a 510 pin problem. Its happened to me before, when I screwed a pin down too hard. Even some 510 connections that are spring loaded are too short, happened on my cuboid.

1 Like

A smok issue perhaps, thanks for the reply :+1:

@Andrissriel is correct …and if memory serves (Vape Mail?) that was a TM clone. 510 threads being 5/1,000ths too long and similar inaccuracies in the PEEK insulator area are common voltage problems. Next time you change coil/cotton, check that center mounted post alignment up top and center pin alignment on the bottom …and if it clears the threads. It can be too tight by a fraction of a turn or there’s burnt liquid hiding in that 5/1,000th (inch)

Thanks for the advice @BoDarc, I’ll take a gander next time I rebuild, I stripped it down and air dusted it out and it seems to be behaving now, however my RX200 went crazy today too, I mean wtf?! first I noticed the battery bar was ‘charging’ constantly, then it kept saying the batteries were dead, changed batteries same thing, I just stripped that down too and did the same air dusting, blasted it out, and now it seems to be ok, I think its a problem with liquid getting into the unit, prob over dripping and not cleaning up properly, no issues at all in 6 months then both my only current mods go down a day apart :rage: my old workhorse the IPV4’s button broke, my mechanical tube has just stopped working (I mean what’s that about there’s nothing to go wrong lol), I’ve ordered a couple more mods today so that I’m covered, and hopefully if it all goes through ok I’m buying one of @Whiterose0818’s mods so I’ll be well covered, the Vape gremlins are out to get me :worried:


Define took it apart As in disassembled it or took the batteries and atty off left the battery door open and blew it out?

hey man, oh this mod died, it just bricked on me in the end it’s on the shelf with my other demics lol, keeping it for spares now, I totally stripped it down and cleaned it out, nothing, dead. it happens to them apparently :disappointed: