Battlestar temp control question

I have officially discovered TC thanks to a friend at work and so far it is great. My problem is that it works fine on one of my mods, (Aleader Funky 160) I can’t seem to get it to work on my Battlestar. I’ve looked all over the net including Reddit but can’t seem to find an answer. I have seen a couple of other people who have had the same or similar problem but no one has been able to answer. When I set it for SS and set the temp and wattage, nothing happens. It goes about 2 or 3 watts and stops. Either it’s defective in some way or I’m missing some important step. I really like this mod. It’s a workhorse that hasn’t let me down before now. Any other Battlestar users out here that can tell me what I’m doing wrong?

what kind of coils are you using?
this is normal behaviour if the mod doesn’t detect a change in resistance fast enough, so it thinks it deals with something different than stainless steel.

One option is to increase your wattage or change your coils to regular round coils (instead of claptons or other fancy coils) or use a higher gauge for your coils so they’ll heat up faster for the same power you apply.

1 Like

I’m assuming you mean seconds, right?

remove tank
hit fire button
screw tank back in
select new coil

This should work. The Battlestar locks the resistance upon sensing a change from the previous fire session and if you switched to TC mode after hitting the fire button may not work properly. This is assuming you have the proper metal type and TC setting on the mod. Good luck.


I’m using basic 24g SS in my Cheetah 2 and SS claptons in my Kylin. Both with slightly different ohms with same result from both. Both attys work fine in TC on my 160 mod so I know that they work for TC, just not the Battlestar. Ive tried various combinations of watts and temp but nothing works. I have even tried TCR mode and set the coefficient at the recommended settings in the manual but no effect.


I guess I didn’t say that right. When I hit fire it only hits about 2 to 3 watts max and won’t go up to the set wattage.


I just went through those steps and apparently that was the missing info. Now it works beautifully. Yes, I now have proper temp control on my Battlestar!!! Thanks guys for all your help. I knew this was the place to ask.


Glad it worked out for you. Drove me nuts when I got my first Battlestar.

1 Like