Broken link between Recipes and Flavour Stash / Flavour List

Sometimes when using a flavour in a recipe, it gets marked as “you are missing ingredients” even though you have the flavour in your flavour stash:

Capture 1

And when you click the flavour, you are taken to an empty flavour page:

And not to the correct flavour page:

Even though the name of the flavour letter for letter is completely identical.

There has been a similar problem for as long as I have used ELR, with flavours that contain special letters like the Danish characters ÆØÅ:

Capture 4

But that is more to be expected. That the same error now occurs for flavours with only English letters is however something I have only seen recently. It is not really a critical error, but still something I thought you should be made aware of.

Could it be you have listed the wrong one?

The second question with Æ, Ø, Å, might be something for @daath to answer

No - I just tested it.

There does seem to be several completely identical letter for letter entries in the flavour list for this flavour, and once you have added it to a recipe, it appears to be more or less random which of the actual flavours in the flavour list it actually links to.

Example 1:
New recipe

Example 2:

Notice that I am selecting the exact same flavour in the two examples. In the first example (a new recipe) the flavour is marked with green text and links to the correct entry in the flavour list / my flavour stash. In the second example (editing my existing recipe) the flavour is not marked with green text, and links to a different entry in the flavour list.

I will suspect that the reason for this behaviour, is that there are completely identical entries in the database, and the software simply can’t handle that. A merge would probably solve the problem, but only temporarily - it would be much better if it simply didn’t allow users to create 100% identical entries.

1 Like

Sorry, for the late reply, but I decided to look into this and think I identified something that could cause this. I believe I fixed it and it should now work as intended :slight_smile:


Thanks. I haven’t done any any actual testing (yet?), but it at least seems to have fixed the broken link in the specific recipe that I had problems with.

1 Like