Cuboid and VTC Mini

New firmware out for both.


Nice! Cuboid is next on my list.

Seems like a pretty minor update for the VTC mini. The wattage down feature is a nice addition but not something I’d use since I just leave it at 50W and only adjust the temp. Don’t know anything about these cubis and BF heads, but since I rebuild 99% of the time I don’t think I’d use it either. Nice that the updates keep coming tho.

Both of mine done and done. :ok_hand:

Done here for my Evic mini, I rarely ever use TC mode so probably won’t notice any difference bar the slightly different display. Glad the puff and time counters are gone, completely useless they were.

1 Like

Theres two options for the cuboid on the new updates. One for 150w and one for 200w. You have the choice. :sunglasses:

1 Like

Not too happy with my cuboid right now. Seems like it can’t read resistance properly. I can put my griffin on with a .45 build and it will read .50, take it off, put it on .54, take it off, put it on, .63, take it off, put it on .47. Also put a SS build in the velocity, lock in resistance set SS 316L mode and it constantly jumps out of TC into power. It’ll work for a while then it kicks me out. Set up different TCR’s for SS and the same thing happens.

There are known issues with the 510. I haven’t cranked anything down on it and the floating 510 still has travel. IDK what’s up with this mod.

Sorry to hear of your problems.
I’m using a crown premade coil and when I take it off and on as your doing it jumps up and down any where from .02 to .05 When I’m using the rba head it holds steady at .26 and it’s not even locked in. I know this doesn’t help you but maybe some one with more experiance will be along to give advice.

Maybe it’s just a bad mod.

Have you done the updates?

Just ordered the Cuboid with the 200w upgrade already done, sent by china post so this could take 6 weeks lol…

I hear you bro. :wink:


Yep, first thing I did when I got it.

The only thing I can think of is that it’s a dodgy connection to the 510 in the mod.
If you have put mod and atty together cold and its jumping about it can only be so many faults. If you have been through all of them and it’s still not right, then its the chip or internal connections.
It seems like you have played about a bit, and still no further on with it, then take it back for replacing or refund.
There will always be the one that doesn’t do as it should with mass production. I’ve had one or two myself.
Sorry I couldn’t be of more help. :yum:

Since update, my Evic mini TC isn’t asking me if it’s a new coil when I put one on, anyone else experience this?

Mine never ask unless the ohms are very different in SS mode.

1 Like

I had the first cuboid work great in TC for 2 weeks,then SS temp mode kept switching back to watt mode took it back,tried 5 more and SS TC,or ni200 TC didn’t work with ANY of them. they only work in watt mode.Never seen 6 bad mods before. Ended up getting another rx200. Cubis is good with .5 coils. Rba deck is ordered. Maybe they can fix the mods with an update but they need to get on it.

After more research and viewing again Daniel DJLsbvapes video review on the cuboid, he suggested setting custom TCR of 0108 for 316L ss. I did that, I also purchased a spacer KP Mod guard .5mm from kidneypuncher and put that between my velocity mini & mod and so far have had no problems with it jumping into power mode. I have not tried these spacers with my Griffin yet on the mod to see if it reads right resistance. Work all weekend so will have to wait till I’m off to mess around with it again but for now I’ve got TC working properly.

Good to hear buddy. :ok_hand: