Don't know whether to be done with LiPo's, DNA chips, or both!

The most favorite mod I’ve ever owned has been a Lost Vape Halcyon. 900MaH LiPo, DNA200. DEAD! Replaced the battery, and STILL will not take a charge. My next favorite… A DNA200 Panzer, DEAD! Replaced theLiPo and got a month out of it before it’s doing the same thing as before (and the same thing the Halcyon is doing)

I’m frustrated, and was considering a new mod from either Rebel, or Boxer, but now, I’m not sure it’s worth paying that much for a DNA chip squonk mod. Anyone know how the sx550J chip is holding up? Any other alternatives for a dual battery squonker out there? Or at least talk me out of abandoning the whole mess! Anyone?


Have you contacted Evolv customer service? If not that would be my first step as they stand behind the board no matter who makes the mod. I recently posted about my experience dealing with them and it was on a mod that was way past the warranty period.

Read this if you have not seen it.


I agree with @wvsanta. Contact Evolv. They’re great with customer service.


I’ll have to contact them. The Halcyon is at least two years old, the Panzer only a few weeks newer. The Panzer in particular is a real disappointment. It worked for about ten charge cycles, and my girlfriend was using it. It quit, and she never said anything. By the time I realized that it wasn’t charging, over a year had gone by. When I opened it up, three was a chunk of solder on the 510 connector that had rubbed a spot on the LiPo, and it was so puffed up that I was nervous removing it! I got a replacement battery at a hobby shop, add it worked great for a few weeks.
I decided to try replacing the battery in the Halcyon since that appeared to fix the problem in the Panzer, but… Nothing.
I’m gladyou had Good C.S experience. Makes me feel hopeful!


From what I am understanding and from my own experience Evolv does not care if it is out of warranty. If it is an issue with the board or the screen they will fix it Free and even pay the shipping back to you.

This is the reason I will Never buy another regulated device that does not have a DNA board.

This link should take you to there Contact Us page

EDIT: Just tired the link and it works then click on Technical Support Tab and fill out the form.


Thanks! I’ll be on that pretty directly! I really hope this works, and that I can get my Halcyon at least working again! You have no idea how much I miss higher wattage temp control squonk!


Good luck, this was their response to me a couple of years ago.

Manufacturer/Model of Device (Mod Name): hcigar vt133

Hi I purchased this around july 3rd and everything has been great until yesterday. I noticed the display fading in and out then it just quit working. Is there a fix for this or something you can suggest. It shows connected in escribe and fires correctly.

Date: 2016-10-05 13:05:53
Name: Nick Coutris
Printer friendly version

Hi Clayton,

This sounds like a screen failure, which we unfortunately do not warranty. Most of the time the issue here is a problem with placement of the screen ribbon cable unfortunately. If care is not taken to tuck it out of the way when the fire button is pressed it will contact the screen ribbon cable every time it is pressed causing failure over time and leading to issues like what you are seeing.

If a replacement is needed they are available for purchase here on our website however.

Nick Coutris
Evolv, Inc


Not sure why you got the response you did.

In my case the issue he described to you was what the problem was with mine.

I even informed him the mod was out of the Evolv warranty period and I got a very different response.

Just a simple We can fix that. Send it to us and we will fix it for free and ship it back to you for free.

I can tell you the screen was indeed replaced on mine because when it came back to me the screen was a different color. The old screen was a much deeper shade of blue and kind of dim and the new screen is much brighter and almost white in color.

I guess maybe they have changed there policy. My reply was also from the same person at Evolv.



Just got a message from Evolv. They gave me a RMA number to send it in! This is NOT AT ALL what I expected! If they fix this issue , at least on the Halcyon, I’m a loyal customer for life! I’m used to customer service giving me the run around. This time, no B.S., no hassle, just sent the RMA form and instructions!


That was also my experience and in my opinion there turn around time is super fast. Hands down the best customer service I have ever dealt with.

1 Like