ECX website

Has ECX been down for everyone else?

I haven’t been able to access it the past few days :frowning:

1 Like

I haven’t had any issues. I was on yesterday and I am on now. Their website is a little wonky though, like it takes a while to load pages, etc.

Maybe clear cache, cookies, etc?


It’s slow, has been every time I ever used it.

Clear your history, and I hope you even have WinCleaner…
Just went there to check…fast as a fart that slips out of Mama’s butt…tweet ! toot!
Sorry, that’s right, females don’t fart.


Okay, so I had to do a disk cleanup to access it… Weird.

Anyone know why that happens with that site? Never run into this issue before.

1 Like

I’ve seen the sight be alittle slow. But it is more on the user end. Most of the time it’s pretty fast. I only had one issue where it dumped my whole order. But that was probably my fault. :slight_smile:

Disc defrag?
I see no reason for that. Just a clean/clear of history/registry.
I guess it depends on your ‘settings’ and your security brand of choice.
I use Vipre, and it even asks me if I want to scan the site. Even if I disregard it,
it works fine [ECX] .

No… its kind of slow lol… I have pro level crap cleaners.

Disk Cleanup=/=Disk Defragmenter

Ya, that’s weird.
No problems with other sites though?
You just may have too much clutter, especially with invalid/broken registries.
Have you cleaned your Registry lately?
The geek gurus claim there are over 300,000 new viruses every day. No virus protection can catch every single one.
The ones that slip through must be removed or quarantined.

I use Vipre security on all devices [desktop,laptops,tablet, phone]
I clear History everyday, and every 1-3 days I run WinCleaner,
and each week I run FixMeStick.
I am on 100-300 sites/searches every day.
ECX runs just as fast as any other site I am on.

I havnt been able to get on either

Try a clearing browser data and if that doesn’t work then do a disk cleanup.

I use my phone and do regular maintenance. It’s only ecx I have problems with.

I feel ya, I think its odd that ECX is the ONLY site that I have had this issue with.

I think it is run by someone who roams around on these forums (I can’t remeber who) so maybe the server they use for the site is just picky since its not a HUGE business (yet).

But as everyone said, just clear some data and it should help.

Maybe the owner will post here with some advice?..

Are you sure you’re thinking of the right site? ECX is one of the top DIY suppliers and it is pretty huge.

I’ve experienced a lot of trouble with the site also. I’m on a Mac and it will run okay on Safari but not on Chrome. I think @DarthVapor had some trouble with it as well.

There are a couple people here from there (@DonovanECX and @ecigexpress) but I don’t think either of them ‘run’ the business…do you guys? Either one of you able to shed some light on what’s up?

I just mean in comparison with a site owned by a larger company like Sony or Dell.

ECX is great, they have most of what I’m looking for on one site that’s why I was so bummed I was having issues. They ship super fast as well!


Yeah, their mobile interface is kinda clunky. Desktop it should be fine.

The speed that any person gets on our site is mostly limited to how fast their local ISP, is and how much traffic is going through their local box, which fluctuates throughout the day.

GTMetrix is showing us at < 4 second load times @ peak times. We beat Amazon by 5 full seconds in the most recent comparison.

It could be your local ISP is caching something or your browser. But every site has this same issue with some individual visitors (even Amazon). Go ahead and clear your cache/cookies.


Kind of funny that right after you posted this it started working again. It has been down for about a week for me and I tried from several different ISPs.

1 Like

How strange! I’m glad it’s working though :slight_smile: