eLeaf iStick Pico No Atomizer message

I have a SMOK Micro TFV4 tank with a 1.8ohm coil in it. This works fine on my Aspire Pegasus Mini mod. However when I put this tank on my eLeaf iStick Pico mod, it does not recognise the tank and I get a No Atomizer message when I fire it.

The same eLeaf iStick Pico mod works fine with my other tanks.
I’ve cleaned the contact on the mod. The spring action on the contact works fine too. The Smok micro TFV4 does not have a screw on the 510 connector, so there is no possibility of increasing the length of the connector.

Any suggestions please?

Don’t use the Smok TFV4 on the Pico. They’re obviously not compatible :grinning:


I am sorry you are dealing with that! Irritation 2X!

1 Like

Could it be because the coil is too low?

Not sure.Its a pre-buit coil and it works fine on the other mod.

Nm sorry I misread it at as 0.8ohms instead of 1.8ohms

Mind u even 0.8ohms wouldn’t be a problem lol, my brains not functioning properly today

I have a TF-RDTA that does that.

Try this…
Start the threads in the mod.
Push fire button and release.
Screw tank down on mod.
Push fire button and release.
Read screen for results.

A trick @Wings4Life taught me with another problem.

Thanks, will try ASAP. What do you mean by "“Start the threads in the mod.” ?

Screw the tank partially into the mod…less than half way.

I kinda had a similar problem … my Eleaf Istick 100w also reads “no atomizer” regardless of the type of tank or rda I try to use on it. I just gave up and it’s pretty much been a paper weight ever since …

I used these for 4 reasons:

  1. Saves your mod’s internal threads–wear protection.
  2. Makes RDA easily finger accessible.
  3. Claims to be adjustable for the hard to reach RDA contacts. Never had to adjust
    with using this feature. Contact is positive with RDA and mod.
  4. IF cross threaded, this decorative chrome plated brass will abrade rather than RDA (or mod if the adapter was not used). – sacrificial thread

In short, can connect and correct almost any poorly made 510 connection.
510 to eGo/510 Converter Adapter

Tried this,still no luck .

Bummer…suck-city, eh?