eScribe for Macs - update working

FYI to any DNA200 users using a Mac. Previously Virtualbox was not working as an option for running eScribe with a Mac. As of today I’m running OS/X 10.11.3 El Capitan and just downloaded Virtualbox 5.0.14 and installed the extensions. I plugged in my DNA200 Reuleaux and the angelic choirs went off in the background. I’m a happy camper!! If anyone is struggling with eScribe on the Mac, please feel free to post here or PM me and I’ll see if I can help.

:joy::joy::joy: :clap::clap::clap: :+1::+1::+1:


How is that working out overall? I’ve been postponing the upgrade to wait for them to get the bugs out.

1 Like

I haven’t had any issues and I upgraded immediately after it came out. As with any OS upgrade the issues are usually with third party app compatibility. Mine all certified in the beta and it went smooth. The eScribe software was never coded to run on a Mac at all. Virtual Box allowed eScribe to run in a VM environment. It just wouldn’t connect to the DNA 200 even though eScribe would run. The 5.0.14 update to VB magically fixed that.

1 Like

That’s good to know, I might eventually take the plunge myself :grinning:

No rush. Not like there were a ton of oh my gosh gotta have it new features. If it ain’t broke no need to fix it.

1 Like

I just leave it as it is then. My experience with these upgrades is they tend to usurp space and slow things down too.

Hell. Yeah about time lol

Hi, could you tell me what extensions I need and where you got them?

Thank you,

1 Like

Here -->. Virtualbox downloads

The expansion pack is the next to the last item in the list. The version number needs to match the version of Virtualbox you are currently running.

Thank you very much it was very helpful and it worked!

1 Like

They are now offering a beta of eScribe that runs native on MacOS for those that may be interested. Just downloading it now for myself. Here’s the link if others are interested.

1 Like

This is great news. VirtualBox works well enough, I guess. Though I often have problems with it detecting my USB port and have to do some tinkering to get it working. But a native app for MacOS would be so much easier and likely work a lot better and more consistently.

I downloaded it and updated the firmware service packs on 4 DNA 200 and 133 devices. The interface is the same thing we had in the virtual machines so no learning curve. I’ll drop a note if I run into any problems. My opinion is give it a try.

1 Like