Hcigar VT75 DNA75

I have had it 6 weeks and it has taken a dump.There is a short somewhere and I am about to open it up and take a look see, just wondering if any body else has had trouble with it.

What’s the problem? Is it still doing something or is it completely dead? I wouldn’t take it apart, can’t you give it back to the shop you bought it from after only 6 weeks?

1 Like

It will go dead and after a few min. it will work. when i hook it up to escribe it shows the volts going up an down. then it goes blank.

  • i bought it from ecig.com for $53.00 which isless than you can getthe chip for so I was thinking of doing my first DNA build
1 Like

Could be a dodgy battery… have you tried different ones?

Make sure you have the latest firmware. There were some issues with battery life on some of the earlier firmware for DNA 75s.

@Bad_Influence yes I was hoping it was the battery even though it was brand new 26650 the other one is about 4 weeks old the same 26650 recomended by mooch.

@mstokens and yes with the firmware, I was pretty happy when the fix came along

1 Like

Before cracking it open, I would definitely ring up the fine folks at Evolv and see what they suggest!

No point risking voiding out your warranty unless absolutely necessary! :wink:


I’ve had my VT75 for a few months now and zero problems with it. In fact, it’s pretty well-built from what I hear (and how it feels to me), so I’d recommend getting in touch with the vendor or Evolv to fix the issue.

Here are some pictures of how the mod looks inside. In Chinese, but you can see the pics.

And here is a video of someone taking the mod apart for you. He starts at 07:50.


thanks, the pics were helpful. i couldn’t get through the vid though

I read about a similar problem a few days ago. Here is the response that the poster got from evolve. It may or may not be the same problem you’re having but it’s worth a look.

"On the bottom of your VT75 you will see a screw next to the battery cap. Can you try to ensure this screw is tight, as well as the center pin screw on the battery cap?

The one not on the battery cap is the ground for the device/board, and the behavior you are seeing could occur if that screw is not tight and making a good connection."


Do you have preheat set to 75w ? i find that causes a lot of voltage drop .

also may be worth trying the csv for a 26650 from http://dna200-themes.de/wpdm-package/ijoy-inr-26650-4200ma/


thank you @louiesquared and yes i have it tightened down. i went around and tightened all the scrēws and at first i thought that fixed it but i after a min. itwent blank again