Just repaired a couple of RX2/3

I wrote this for anyone that is getting a weird battery message on their RX 2/3 and won’t fire. I hope it helps…

So my vape buddy and I each bought one of these a while back and he dropped his because he’s brutal on his mods, and he would get a “balance” message just above the battery icon. It wouldn’t fire at all and the battery indicator showed depleted batteries despite being fully charged. He loved his mod and I hated mine so I gave him the one I had. Well, last week, he dropped that one and he got the same empty charge icon and some other message which I forgot to remember. All other displays worked fine. He could switch settings, adjust temp and wattage, it just wouldn’t fire.
I told him I would take it apart and have a look. If you have a similar problem this might help.
Be patient and work slow. There isn’t a lot of room to work with on this thing.

You’ll need a small philips screwdriver, needle nose tweezers, and a soldering iron. Wish I would have thought to take pics, but there are a few tuts on the internet if you want to search for it.

  1. Remove the battery cover and batteries of course.

  2. remove the 6 screws holding the battery sled. The faceplate will drop off. Be mindful of the up/down buttons as they may fall off the faceplate.

  3. look for the little foam plug near the top left battery well of the battery sled and remove it with the tweezers (or a small screwdriver, paper clip etc). Remove the brass screw you see inside. This screw will probably fall into the mod. If it does, don’t panic - just put the whole mod into a baggie and shake until it pops out.

  4. set all the small parts aside so you don’t lose them. I set them on a large magnet.
    (On the bottom of the mod, on either side of the battery release button, there are two torx screws. Don’t loosen or remove them.)

  5. Gently pry the top of the sled out. Too much force and it will break or crack the plastic casing. Get it out far enough that you can see the top (the bottom will still be attached to the mod by a short thick wire. Pulling too hard on the bottom may break the wire or solder joint) and remove the two phillips screws holding the battery contact cover.

Caution, there are springs underneath that may jump out so be prepared.

  1. Over the right battery contact you’ll see a very thin red wire that has broken off and will need to be soldered back in place. Take note of how this red wire is routed to the back of the battery sled. It’s important.

If all your wires look intact, stop this procedure as this will not fix it.

  1. Very carefully, strip off some of the insulation from the broken end of your red wire. This wire is way too thin and pulling on it will break it (another reason I dislike these things).

  2. Once you’ve stripped away the insulation, solder your wire back onto the battery contact, make sure your springs are back in place and screw the contacts cover back on.

  3. Make sure you route that thin red wire to its original position. You don’t want it to get pinched by any part of the sled, body or screws. This could cause a short and fry your mod.

  4. Put the sled back into the frame and screw in the brass screw making sure the screw is going into the brass eyelet and into the frame.

  5. Make sure your up/down buttons are back on the faceplate and put the plate back into position on the frame. Screw in all remaining screws into the battery sled.

  6. put the little foam plug back into the hole above the brass screw.

  7. Insert batteries and test.

This appears to be a common problem with this model after it’s been dropped and should get you going again. Good luck!

EDIT: steps 5 and 6 have been edited after learning more info. Thanks @douglas77 for the info!


You clever bunny, you! :smiley::tada:


I’m so bright my parents call me sun.


Solid bit of work there! Thanks LostMarbles.


Great write-up Lostmarbles!!

A great share that should hopefully save some folks having to discard a mod!

Excellent tip!! :thumbsup:


Thanks and thanks for reading!

1 Like

Thank you. Learned the baggie trick the hard way. Every time I run the vacuum cleaner I can hear the chunk-chunk sound of lost screws and wire leads being sucked up.


Get down @Lostmarbles! Great thread! Mod ER!

1 Like

Thanks brother. I appreciate you taking the time to read it.

Oh hell ya!

1 Like

I had to do this with 2 of them also, must be the biggest problem with the RX 2/3.


Another issue is the screen going blank. I got my RX300 i babied that thing. Never dropped it or left my desk and in 1 week screen goes black. Had to watch a youtube video and solder the last two pins under the display which was a pain and if this happens i might just toss it. sounds like they released some hazardous products. Predator that auto-fires when juices leaks and now rx300 that might have a wire pop off lose at anytime. nice…

1 Like

Maybe you could start fixing them and re-selling them as re-furbished mods? I so loved that mod when I first got it but it wouldn’t do the TC as advertised so I don;t know, I kind of just quit using it.


Yeah, I was surprised at how often this would occur. I’ve sworn off of the Wismecs after having the 510 issue with the RX200 (and eventually having the board catch fire) then seeing how thin the wiring on the 2/3 is. Thanks for reading.


Not a good sign. What gets to me is they won’t accept responsibility for a faulty product or try to do anything to make it right.

1 Like

I had the same problem with the TC when I had mine. Got tired of taking the atty off, hitting the fire button and reattaching the atty back on. It was a very frustrating PITA.


it’s a cool looking mod, can’t deny it.

1 Like

Think I have done 5 or 6 for customers now all with the same issue which is pretty damn bad. I will never sell another wismec mod even if they appear to have upped their game.


I’m not sure I’d refer to anything as hazardous and then chase the comment with juice leaks…

Yes, eliquid getting into components/battery compartments can develop into a dangerous situation. But I wouldn’t necessarily call that a hazardous product. If anything, I’d blame the atomizer for leaking and creating the scenario first* and foremost.

*IF we were talking squonkers OTOH, then yes, the statement/assertion might actually apply.

FWIW though, I appreciate your tip (sharing) about the lcd issue, and the possible fix. That might save a forum member from losing a mod that’s “easy to fix” (with the right tools and skills of course)!


Mine is at the drawer waiting for this kind of repair, this weekend. Glad to have read this!
Thanks mate!