Koopor Plus 316l ss tc help

Any one get temp control working on the koopor plus with 316l ss?

Usually you can get it to work by going to settings, adj. ohms then put it as far down as possible (smallest number)… At least that’s how mine behaves…

nope, i think mines just off. tried alot a shit. Negotiating with koopor then the went silent x\ just want this to work

Sorry to hear that :confused: I haven’t heard of many Koopor Plus duds, but plenty of Xcube duds - both of mine work … sort of OK (I have to adj. ohms most of the time)…

EDIT: Did you try messing with the SC/DC option along with the coefficient?

Good luck my friend. SS doesn’t work very well on this and if it does it won’t work consistently. I use Ti and so far, it works pretty darn well on a consistent basis. Trying to get SS to work on the koopor will drive you mad.

To be fair, a lot of mods struggle with SS wire - even DNA200’s have their work cut out for them - it works, but Ti works better! :slightly_smiling:

Though oddly eVics seem to function fine with SS!


I have only used 304 SS wire, but it seems to do fine. Mostly I use Ti wire though so I have only used the SS a few times.

on vtc mini its works great, the koopor aint shit

Never had much luck with the cube and ss 317l, 316l and 304. 304 seem to fair better but still jumps back to watts. Just annoying. Especially when the e vic mini does all 3 types no problem.
Just waiting on the right buyer and the cube will have a new home and i will get a new mod that just works.

Any ideas on tcor settings for SS on this yet?
Trying to get a Uwell tank to work w SS

I’m using .00097 on mine (316L) and it seems to be working OK. You can try .00092 - .00097 and it should work for 316L
317SS try .00088

Good luck. The Koopor + is a finicky lil’ shit.

I messed up I think, it’s for the Uwell and I think that’s 304…this isn’t my gear just trying help a fellow vaper.
Thanks for your help @Lostmarbles

1 Like

No problem.
try .00105 for 304ss.

1 Like

Yeah, it was too finicky…didnt work and we both lost patience.
But thanks again for the help!

Is it not hot enough? If so go into the AIO and up the resistance slowly higher than your actual resistance. I have found this has worked for me…