Lemo 2 Connectivity Issue (FIX)

I don’t know about you, but to me the Lemo 2 is the best single coil RTA I’ve tried to date. I could appreciate a bit more air flow but it’s adequate and I find the flavor and vapor production to be better than average. When it works that is.

The problem is in the design. Eleaf made the positive pin a 2 piece unit that works by screwing the two-piece base together which is supposed to force contact between the two positive pins - one on one half of the base section, one on the other. However, that contact can be less than solid to say the least. Sometimes it will not make contact at all. As if relying on two pieces of metal being pressed together for an electrical connection weren’t silly enough, Eleaf’s design team also made the pin(s) too short by just a tiny, tiny bit. After much aggravation I found a simple fix.

Take the base and unscrew the top section from the bottom -

Now unscrew the pin from the top section -

If the insulator you see on my pin doesn’t come out, gently pry it loose with a precision screwdriver then place it back on the pin. Now, place an o-ring on the pin so it sits on the insulator. Here’s a photo of the one I used -

Then just re-insert the pin into the top half of the base and tighten down. Get this rather tight but not so much you’d have trouble taking back apart. When you put the two halves back together, that o-ring will have essentially added a bit of length to the pin, making the two halves touch with more force, thereby creating a better connect. And when you screw onto your mod, the pin will have even more pressure applied to it. Since I’ve done this I haven’t had any more connection problems.

I might add that my first fix was like this, but I had a silicon grommet in my desk drawer that i used. Just don’t remember what I got it off of. I had to cut it down because the first time it made the pin sit too far out so that when I put the base pieces back together, the part of the pin at the 510 was then pushed out a bit.

If you try this fix and it works please let me know.


When mine was having issues I noticed that ther was quite a bit of movement up and down on the AFC ring. I took it apart as you did but using scrap wood I drilled a hole in one piece to protect the threads put another scrap of wood across the top and gently pressed it back together in a vice. I put it all back together the AFC ring was nice and tight and it worked like new.

I have the Lemo no 1 and the only connection problems I’ve had with it was, ironically enough, when I put it on one of my iStick 50’s. You would think that they at least make sure their products work with each other :slight_smile:
It works fine on my other mods though and the iStick is just gathering dust for the most part, but it is good to know there is a fix when necessary.

Thanks! I have a few lemo 2 and one of them kept randomly doing the ‘no atomizer’ thing. I did your fix and it’s working perfectly.


I have a few Lemo 2s that do the o atomizer notice. Took one apart so far, did not get the o ring yet, just barely screwed the pin back in and it started working.

1 Like