Looking for a new mod...suggestions?

I have been using the xcube ultra since about October and I absolutely loved it. It died on me almost 2 weeks ago now and I have been looking for a replacement. I ordered the smok alien, received it on Monday only to find out that it was faulty. The screen shows it is firing but it isn’t. I have turned it up and turned it down and everything I know to do and sometimes it will work but only if you are lucky. I am in the process of sending it back and now I am wondering if maybe I should try a different mod. I have heard that sigelei’s are pretty good mods. I need something that can do high watts since I am using the cloud beast. I don’t know if I should just request my money back or get a replacement. Thanks

Depending on your budget, you can’t go wrong with a DNA 166/7 (Therion for example), or DNA 200 or 250 (Triade, which is 3 batteries), or SX Mini QMini, they are the most reliable and accurate mods out there, but they are not cheap.
The Asmodus Minikin V2 is a great mod and cheaper than the others I mentioned.
The Sigelei Fuchai 213 is good providing you don’t need more than 150W, because it doesn’t do the 213W that’s promised.
I suggest you watch some Youtube reviews.
On saying that, the Alien is also a very good and cheap mod, I think you just got unlucky with the one you received.

I have two Smoks and their flawless. An Alien and a GX350. Sorry to hear you got a lemon. Sigelei is an odd bird. I love the looks of the 213 but the reviews are terrible re: DJslb Vapes reviews. Having said that, I know a lot of folks that have them and love them. The three big knocks against the 213 are: It only produces 155 watts. Temp control does not work well at all. Even though they claim it can be upgraded, it can not. Wire traces on the main board go nowhere.

I was really bummed when the alien didn’t work. My xcube ultra was an excellent mod too. I never had the first bit of trouble out of it then just all of a sudden when I went to hit it the fire button switched to Bluetooth and the wattage went all the way down. The cloud beast threw a lot of condensation up on the display since it was on top, I bet the board got a little bit wet or something from that and fried it. I took it all apart and cleaned it as best I could but it never worked the same again. I think I’m gonna tell them to replace my alien and I will try another one but I still think I will get a backup for when I need a change or just in case I have something catastrophic happen lol.

Do you use or care about TC?.

Have a look on my site man theres a few bit and pieces that might interest you on there, reviews n stuff 🖒 www.steampugs.co.uk


I was going to suggest that when he told us what he was after. I had the link copied an all lol

1 Like

I’m not really concerned about tc at all, I have not ever really used it, I like the straight power! I’ll go to that site and check some of those out! Thanks

1 Like

Look up PWM mods. They are very high powered, adjustable, and have amazing ramp up. They give excellent battery life and the flavor from the “pulsing” is out of this world. They are strictly power, no TC at all. After you research it and you think you might be interested, lemme know, as I might know a builder…:sunglasses:


I waiting for the new lost vape Drone BF (Squonker) DNA166to come out .

1 Like

Still use my HCIGAR Vt133 (DNA200) …always perfect. So had to get the HCIGAR Vt167 (DNA250) …very happy, several improvements make it perfect-er. Plus I got it for $76 on a crazy Flash Sale. Check the “Good Deals 2017” thread daily for deals

Oh and fix your X-Cube …disassemble, degrease, reassemble-> good


I have tried to fix my xcube, it comes on but the fire button turns on Bluetooth and the up button turns it to temp control and the down button actually just turns the wattage/temperature down. I have cleaned it with alcohol again and again, I thought about reflashing the firmware, but they don’t support mac so I have to wait until I can access a windows pc. I don’t know what else to do with it. It just did it all of a sudden never had a single problem out of it before that.

1 Like

Smok gremlins man, I’ve suffered many times, My Xcube went completely mental so I gave it to whiterose for spares, oddly if I left it on the radiator for a day it worked for a day…

maybe Ill take a hair dryer to it and see if that works! If that doesn’t work then Ill try a small bon fire. That should make some smoke lol.

1 Like

I thought I was the only that suffered from Smok Gremlins. I have one that I used 8 days and it started spazzing out. What the buttons actually controlled on any given day was a crapshoot. To quote Forrest Gump, “Smok is like a box of chocolates. You are never sure what you’re gonna get”