New to vaping help?

I just bought eleaf istick picko mini with a mello III tank , first month it was great then problems started happening. First i changed the coil from “0.3 ohm to 0.5 ohm” because it tasted like it was burned and every time i take a hit it hurts my throat , then the new coil did the same thing , anyway I bought a whole bunch of new 0.5 ohm coils and 0.3 ohm and now it’s not connecting at all it says no atomizer whenever i try a new coil it only works on the first burnt one … i tried screwing the tank i tried unscrewing it i tried everything i saw on the internet still no atomizer… help?

1 Like

Any chance you bought those at fast tech? Got a bunch of coils from them not working, is your coils authentic? If not get the real one.

1 Like

Some of the coils eleaf make are for mtl vaping the holes in the coils have a silver cover (you can’t see any cotton) they usually put one in a kit. If you take a big hit you can get a dry hit and burn the cotton.

As far as the no atty - you will have to take it all apart and make sure it is all screwed together properly, clean out the 510 connection on the mod, hit the fire button with no atty attached to reset the ohms. I haven’t played with a pico so I am just giving you some broad stokes to start off.


And be sure you you use the coils within the limits they have wattage wise. If you use to high wattage on a coil you will burn the cotton and render the coil useless.


Another point, when priming your coil, do it from the top. That way you are soaking the coil from the inside out.
Make sure and let the coil sit a few minutes and work up to your desired wattage to break it in.


I bought coils online for a super awesome deal…then i realized they were burning red hot and were ready to explode on me. They would also short out my tank…
Word of caution. By from a local vendor or a reputable online vendor. Sometimes a super low price is not a good thing!!


I don’t know if the coils are authentic but i got them from the same guy i got my eleaf from and I checked my security code turns out it is authentic… they’re pre built coils any idea how to find out?

1 Like

Thanks for your help , and i did all of the above but I’m sure it’s a connection problem between the coil and the 510 . Because I bought another patch of coils from a known store online but still they’re not working ! Could it be the tank ? I broke the old one and changed it

1 Like

If none of the coils you purchased worked, than yes it is problem whit the tank just to make sure that you got the wright coils for your tank, the coils i got where like 2 of them were working on a 5 pack, you change the glass of the tank? Even whit only the base and the coil in place it should work… hard to help distantly check the base if the pin that goes to the midle of the 510 connection is there or spoted burnt than if the coil screw in to the end of the treads if all than time to buy a new tank! Maybe try rebuilding it is easyer than play whit a thank that just wont make it, can be very frustrating…

Most tanks that use factory/premade coils use a floating positive pin in the 510. Sometimes that pin can slide out just enough to cause connectivity issues like random resistance reading fluctuations or no resistance (AKA No Atomizer) being read.

To see if this is the problem, follow these easy steps:

  • First disassemble the tank and remove the coil from the airflow base
  • Take the base of the tank, and while holding the face of the positive pin(The gold/brass/silver shiny metal circle in the center of the 510 connector) parallel to a hard surface. Gently but firmly tap the positive pin on the hard surface three of four times.
  • Reinsert the coil to the base, then mount the base assembly to the Pico.
  • Press and release the fire button to get the mod to read the resistance of the coil, but DO NOT fire the the mod or you WILL fry the cotton in the coil and render it useless.(If the coil was previously primed with fluid, go ahead and drip a couple of drops into the coil. If the mod does fire the coil it won’t fry the cotton)

Hopefully the Pico will now read the resistance of the coil, and do so correctly. Finish assembling the tank, fill and enjoy! If these steps do not work, then you got a sleeve of bad coils. It happens. It’s rare to have them all bad, but it does happen(It happened to me with a pack of Kanger SubTank coils and was ultimately what got me into rebuilding) I don’t know if the vendor you purchased them from will replace them seeing as they contained a valid Authenticity Code.(This is also what happened in my case, unfortunately.)


Thank you very much i tried everything but what worked was i cleaned the 510 gold Pen with alcohol using a q tip sorry for my English it’s my second language. Also I screwed the coil so hard it worked

I apologize. I neglected to mention cleaning the 510 of the atomizer-If you haven’t done so, also clean the 510 connector on your device. A good amount of dirt likes to hide in the threads, and dirt makes for poor electrical connections.

As to your English-It is excellent. You’ve got a better command of the language than most native speakers! Glad to hear that you’ve gotten things working-Nothing is more frustrating than malfunctioning equipment, be it vape, or car, or anything else! Cheers!