Noisy Cricket II

So I have been going on about the combo of the Noisy Cricket and Moonshot. Still a lovely combination but as has been widely reported, the fire button is crap. Rather than investing further by getting the fix for this I opted to purchase the Noisy Cricket II. Great little mod. Not exactly mechanical like the original, but is has unregulated mode (or whatever they call it) along with the ability to run in series or parallel. This is especially helpful if you want to run SS coils or other builds that are low ohm. I’ve been using it all day so no experience with long term use, but so far it’s fantastic.


Well, let me tell you, the Noisy cricket II was sent to me for review last Monday, I bought the neutron to go with it for the purposes of the review, it was an amazing pairing, then 8 hours later the mod went quite quite mad, and 2 hours later it was bricked. The company that sent it me have decided to send me something different to review instead so respect to them, Wismec however asked me to send them a video of its issue (I sent a video of it not working…??) And they just said they’ll mention it to the engineers, so I may just do the review anyway, suffice to say it won’t be a good one :expressionless:


I’ll be keeping my eye out for your review. Also I will post any unusual findings with mine. And it will be used a lot I can assure you. Any glitches and will be posted here.


Still going strong. I’ve put this thing through it’s paces. Been vaping it all day…hard…and not a glitch of any kind.

Strangest thing man, I put batteries back in it after leaving it on the radiator for a while, worked, then 5 minutes later same thing happened again, I’m actually tempted to buy one coz when it was working it was amazing, and I’m putting mine down to being a duff…it happens I guess…

Could be some bad wiring or board. Maybe that potentiometer is faulty.

Try this. Click 5x and turn off. Then hold fire button till the light comes on. Red light and it uses the potentiometer. White is basically a bypass (mimic of mechanical) which is the only way I’ve used it. Once you get the white light, click 5x to turn back on. Of course this also means you need to know if your build should be parallel or series. If above, say, 0.4 ohms you’re ok with series. Under that you should use parallel. Pull the battery cover. That’s a plate that the contacts are on and it pulls out and is reversible. P for parallel and S for series…the correct one facing up. You probably already know this but for the benefit of readers who don’t :slight_smile:

If you try in bypass mode and it works, then it may be safe to assume a bad potentiometer.

1 Like

yeah I did know all that I read it on the website before I started it up, I’ve only been using it in parallel as the Neutron was about 0.2, I’ve just put batteries in again and it came on constant and wouldn’t change to variable when it was off, it worked, then it didn’t, then it started flashing white quickly for ages (on fresh batteries) then it wouldn’t come on until I pulled the battery cover off and put it back on again, then I put the serpent mini on and same kind of issues but still kinda worked, then I put the neutron back on again and it’s not blowing half as much power through it…it’s mad…completely mental…it’s kinda workin now, longest it’s worked since yesterday…

1 Like