RDA coil help

Hi guys, I’m new to this, but have jumped in head first. I made some various SS316 Clapton type wires today. From a looks & Ω perspective I’m getting pretty much as Steam engine predicted.

However, the vape have no oomph. It’s my first low Ω build down below 0.3. Id think I should be getting serious clouds. I’ve tried at all different wattage (regulated mod) ended up getting to 80w that started getting dry hits. I’m feeling lost on this one. What do you think?

Oh yeah, I forgot.

When I put my RX2/3 in TC SS mode, it just flicks back to VW. HUH?

That’s very odd, RX2/3 meaning Reuleaux correct?

You should definitely have enough power, do you have an aversion to kanthol?

I NEVER use temp control on an RDA, VW mode all day to kick that power.

With that low of a resistance, you should be having no problem getting a satisfying hit.

You are using steam engine, which is exactly what I have always used. What diameter coil? Looks to be about 2.5mm

The rx 2/3 is a bit of a pain with ss - I remember reading ages ago that rx 2/3 doesnt recognize ss 316L or 316 just 304 (cant remember where I saw it or if it is infact the case).

Have you updated the firmware?
It may help.

1 Like

Stainless steel is the one of the best, but this is one of the many reasons I haven’t gotten into it, really. Many inconsistencies (from what I hear).

Very interested in titanium wire but waiting for it to be deemed safe.

Is this your first RDA? Cant be. Just your first coil build, I am assuming.

First RDA, I got a Tsunami as well but both in the last fortnight. It’s like my 5th coil build & installation. I’ve made a bunch of coils lately, maybe 20.

Firmware updated, I.d. Is 3mm

Could the batteries being at 16% play a part. I’ll try with some fresh ones when I get home.

Also might make a simple 24awg separated coil in SS to test if that gets TC going. But am still stumped with the vape in VW mode either way. Learning curve.

1 Like

Posted in wrong thread

Oh another thing you can try is take off the atty fire the rx with nothing attached and then attach the atty - is the mod reading the correct ohms?

1 Like

Ok I just tested a 316l build on my rx 2/3 in tc and it works fine - it may well be batteries.

I also noticed that the wattage was at 150 lol wow head rush

have you set the preheat? (fire and + hold till you see the show logo then plus again) mine is set at 300 lol

1 Like

I’ll Try a few things. If you have any other ideas in the meantime. Let me know thanks.

I’ll let you guys know either way, handy information for young players. If I can work it out.

1 Like

I have built thousands of coils, many very shitty. From the looks of it your coils are B-E-A-utiful, so they CAN’T be the issue.

Are you sure they are SS? Sorry its a dumb question, but I myself have done many silly mistakes.

Also, if they short out, they will not work/ may work kind of odd. Sounds like you are going through coils, pretty fast so once again; probably not the issue.

Batteries DEFINITELY lose some of their kick once below 50%, so I would try a fresh set. Doesn’t explain the switching from temp to VW.

Let us know!

1 Like

oh and double check it is a ss coil a magnet wont stick to 316

1 Like

Also, make sure your batteries are balanced; turn off the device and hold all three buttons until it shows each battery’s voltage.

Always forget about that trick.

I just got home. Had a quick look. You would not believe it but I just noticed ‘atomizer short’ message appearing. I can’t see why. But least I know what is going on. I didn’t realise the mod did that. That’s a good function.

Redo perhaps.

1 Like

If a coil touches the deck or the wall of the RDA and you fire it; instant short.

Not always, but mostly.

Pop a new coil in, easy fix :+1:

Edit: I always look from the top down to see how far out the coil is, just a part of the process you will pick up. It looked so damn good in the pic though, you sure you haven’t done this? haha

1 Like

Looks like the front coil on the photo will be touching the outer sleeve, could be the angle of the shot though …


Just to be safe I would grab an ohm reader, this was one of my first purchases before venturing into building, the guys are spot on though.

Those coils look great, stay safe, don’t blow your face in half or shred your fingers to bits, not mention your mod :grinning:.

By the way if you do have an ohm reader, check a few stock coils in there, that’s what I do.

Also Pentine & Grubby are right on the money. Don’t let that thing touch your deck.

Have fun building :grin:


1 Like

My mod can sometimes jump out of TC mode and into power if the leads aren’t tightened down enough. Those coils look great but a touch on the long side. They could very well be touching the deck. excellent advice from everyone above.

Absolutely batteries can derail your experience - even when fully charged. My HG2’s for example, fully charged, when I try to hit 63W (single battery), don’t do squat. If I look at the LCD while firing, I can see the battery level drop to almost nothing while I’m hitting the button. Voltage drop. My VTC4’s however, have hardly any voltage drop at all. Voltage drop gets worse as the battery charge wears down, too. So, at 16% charge, that was probably your issue. So, for me, I use the HG2’s @52W on my tank for half a work-day, but for my RDA @63W, I switch to the VTC4s.

I haven’t built many coils for RDAs but the few times I’ve used one I quickly went back to single coil builds. It was really hard for me to get 2 coils heating up at the same time. Now I’m sometimes using the Pharaoh which has a different build deck from the velocity style and I’ve had no issues so far. Every build worked, right now I’ve got a ready made 3mm 0.4Ohm clapton which is performing really well. Nice single coil builds can be cloud monsters, too.

1 Like

Using my Pharaoh right now…dual SS GeekVape fused Claptons.

@Volition Personally I would use less wraps …less wire to heat up. My understanding TC requires spacing your coil. Try 5 wraps 3.5mm I.D (spaced) in TC (likely closer to 0.10 ohm) BTW, nice Claptoning mate.