What happened to my DNA200

My wismec dna200 took a dance on me. Not sure what’s going on with it. One minute it comes on and then says check battery. Then it says unbalanced battery then it shuts off. Was working great till I changed the batteries the other night. Now it’s just a paper weight. Went into escribe. Everything looks ok. But it’s not charging and now it won’t fire. Hmmmm well shit

That suck’s and I want them to make a Squonker :confounded:

If you can get it to be read by escribe plug it in and download one of the new escribe updates. If you do one of the beta ones it will do a full reinstall of escribe. I had something similar happen with my DNA200 not that long ago. It ended up being a screwed up USB driver that scrambled the instructions next time I programmed the mod. Reinstalling escribe did nothing. But, when I downloaded the beta version it did a standalone install which also reinstalled the USB driver and mysteriously everything began working on my mod. Give it a try can’t hurt.

Here’s the link.



Isnt this just an unbalanced battery issue?

1 Like

Well it says that. But no matter how we set things in the escribe and tried new batteries. It still does the same thing

Well we tried that. And nothing changed.

On e scribe I would look at each cell voltage when trying to fire the device if voltage is in range of soft cell cut off then I would restore to a older back up or hard reboot

1 Like

Check were the batteries make contact on one review fellow squeezed the mod with clamp to fix lose battery door the Fram spread witch can cause poor battery contact and balance battery error message

1 Like

You might want to lob a ticket into the Evolv guys. That’s what I did and they were good on corresponding to get me up and running. Even offered me an RMA in advance in case I needed to ship them the device. The chip comes with a one year warranty from Evolv even though it’s a Wismec product. If it’s not chip related they will probably let you know.

1 Like

I’m thinking its a battery contact issue. I never did like them little tabs o. The battery slaed.

Update on the wismec dna200. The case was spread just a little bit. I took down the little perfection ring. And I found a wire on the power side on the bottom that was loose. So all that said. ITS ALIVE. AND WORKING LIKE NEW THANK FOR ALL THE SUPORT


There is a u tube video Mike did few months back taking about if the battery door seems lose time to squeeze your mod

It’s all good. I fixed it. Then I gave it to a friend in need. Paid it forward you might say. But thank you for the info

1 Like