ELR Home   Create recipe   Resource page   My recipes/favorites

Hohm Wrecker G2


I can 100% confirm that the latest FSK firmware (2.5.7) works great in Kanthal TC. Tried it with a 0.27 ohm build. But of late I much prefer my SS Claptions for TC vaping, so not using it on the daily.

Until they fix their customer-pays-shipping warranty issue I won’t order one either, and I’m encouraging people not to order from Hohm Tech or Vaporcube. But I do recommend the mod itself. It’s outstanding.[quote=“TheTinMan1, post:67, topic:103780”]
I really want the Slice for 30 bucks because I need another decent temp device. But I will look to DNA.

May well be my next purchase if I can find one at a B&M. Far more portable and since I don’t own any 26650 mods, I’m interested in learning how I would like one.

Sad. If you love it don’t let shitty CS from the mfg company keep you from buying one. Just keep your eyes out for deals with sellers that have a better return policy. [quote=“Pugs1970, post:71, topic:103780, full:true”]
No body else noticed a massive power lag when your batteries get down to 30%…?

I’ve not done enough reading or playing with this mod, but I’ve noticed it too. However, I don’t think what you’re seeing is actually the correct percentage of battery power. Reason is when my vape got anemic and I knew the batteries were getting low I popped them into the charger which read them at 3.33 v. That’s far below 30%. Now this was using the Hohm Life batteries. I notice with the LG HE2 that it will continue to fire good well below the 30% or so on the meter.


Im using my woody vapes now, i wouldnt of noticed that the bats need changing, i just happened to look at the battery bar…when i first noticed the lag on the G2 it was at 46%…it was still ok …but noticeable, when it went to 30 it was almost unusable
I think thats quite bad, that was with VTC4’s and my H2’s didnt feel any different, this woody vapes has VTC4’s in too, obviously i understand that not everyone can have the same experience with a mod, too many variables, but…i dunno…I liked it at first…when it worked…but my confidence is waning with it, I certainly wouldnt of paid full blown retail for it (even though I eventually kind of did)
(by the way @SthrnMixer …off topic…but I mixed your Strawberry Lemonade cake before…smells outstanding :wink: nice work, in the cupboard it went for a month, thanks for that man :thumbsup:)


Every regulated mod I’ve used has done well until the batteries drop low enough. That point varies some between mods. For my DNA200’s that’s usually around 3.6v or so. With the RX200 it’s around 3.75 when the vape starts getting weak. So I will have to monitor where the vape starts getting weak on the HW G2. What the display shows is not as important to me as knowing what it shows when I need to change batteries. If that’s at 40%, I don’t care as long as the mod is still working when there is enough charge left to vape.

Also, the G2 has Auto+TC which, if I’m not mistaken, is supposed to limit available wattage on a scale based on remaining voltage. Again, not looked into it but check if you’re using that setting. If so, the vape is supposed to get weaker to my understanding.


hmm, OK…I’m the first to admit I haven’t delved into the settings so much, I’ll reserve judgement unti I do then :thumbsup:


When you hold the menu and -/+ buttons down to go into the Advanced Insanity menu you will see an option of Auto + TC. You can enable it and it will give you 3 options: battery saver, 51% insanity and maximum insanity.

I highly recommend trying them all. The difference is very noticeable. 51% is pretty intense. Max is insane. Battery saver is weak sauce.

Using the 51% insanity option will greatly affect battery life. I can’t use Maximum insanity for more than a few vapes.


Note that the difference between the 3 options is more noticeable to me when in power mode opposed to TC mode.


When the batteries ‘drop’ in performance on the G2…

On your last charge, what did your charger say the mAh capacity was on that set of batteries?


I don’t have an Opus :frowning:


But I’m using new VTC5a


iiii…dont seem to have that option :confused:
in to Advance insanity menu
scrolls to…
screen rotation
exit (press fire button)
firmware version
upgrade port

…that’s it…nothing else…is it me??


Which is???



Upgrading is the first thing I do


What I found is when you scroll through the menu items you have to press fire to enter the sub menu. So on auto+tc hit the fire button to get to the auto-tc sub menu. Scroll through that and fire to select.


well I figured that, but once I get into the insanity menu, pressing fire just puts it onto the next one…
don’t tell me I have another dud… :rage:


I have used one G2 since black Friday, every day, and never have any battery performance drop.
I don’t use the ‘curve’ setting.
Kayfun V5 .7ohm SS coil 440F 19.5W
I have never upgraded the firmware, it came with 151W 2.4.7 firmware
My batteries fire perfect, all the way down to shut-off, though I try to catch them before, but can’t always pay attention.
@Rob62 asked me to do a build/test in it back in November, and at that point, I had not even un-boxed it. I not only did the test [over the phone], but I have never even changed the wick in it yet !!! (rayon)
Batteries…hmmm, worst lately for falling short of full charges have been the LG HE2’s…awful disappointment. New ones.
How do you know when a mod fails, batteries fail, if you don’t know the charge capacity on your batteries when you install them? I have batteries show full charge after a cycle, yet a 2500mAh says 1640mAh. If I install it, the mod reads FULL charge, but I would EXPECT it to show low performance…even at 46% mod reading. Make any sense?
If you don’t know the capacity of your battery when you put it/them in, how can you evaluate ANYTHING afterwards…and furthermore, are your batteries still equally ‘married’ if one is 2180mAh and the other is 1640mAh ? A ‘married’ pair does not mean they charge/hold/perform equally…EVERY BATTERY HAS IT’S OWN PERSONALITY…just like everyone is not as handsome as Ozo. Capice?


Follow -

Press mode/+/- together to enter Advanced Insanity Menu
Use +/- to scroll to auto+tc control.
Press fire to enter sub-menu
Use +/- to scroll to Enable
Press fire to enable
That should take you to Auto+ TC Level
Use +/- to scroll to the desired level (battery saver / 51% insanity / Maximum insanity)
Press fire to choose the level


Yes, I’ve noticed the power lag too. Not sure at what percentage I’m using lghg2’s - I’ll pay attention this charge see what I can pick up.

I’m sure the auto TC+ is off by default, so I don’t think that’s the issue. I’ve never used it. If @Pugs1970 hasn’t delved into settings then neither then has he I assume.

Just for everyone - all the old coupons still work at vaporcube. Even the 4th of July sale code will still give you half price. This is at vaporcube. Yes the one with the shitty customer service I know.

For the slice $30usd with SLICEPRICE
For the wrecker $65usd with G2FLASHX1
they will work currently, amongst others if you google “the device and coupon code” for other codes that will work from their past sales It’s like they don’t know how to turn them off. Can TC kanthal but can’t turn off old coupon codes. Or maybe no one is working there now. It’s just a website and 1 guy packing orders I suspect.

Now use PayPal to pay and use their dispute process if you have problems. You will get treated as you’d expect if the unit is faulty or not as described.
Visa & MasterCard have buyer protection too. But I cannot talk them as I’ve not used that process. My understanding is its just as good, but do not take my word for it. Look that up yourself if you don’t use PayPal. You will get the protection you desire and expect on purchase.

I agree with @TheTinMan1 and think everyone if they are a mod collector or hoarder ( most of us , yes) should own 1. They are interesting and different enough and good enough to warrant a place in any collection. Note any videos you watch that state the TC doesn’t work,most likely don’t understand the settings. I got good TC with even a SS core nichrome mixed metals wrapped Clapton’s twisted together in xXx mode.

At 50% battery now still chuffing. Should lag soon huh, let’s see when.


what you shouting for…jeeeez Ozo…lol


I wonder how much commission @Volition gets per sale :wink:


that’s my problem man… auto+tc control isn’t there…it’s not an option, I know how bizarre that sounds but i have been through this menu now a quite frankly…offensive amount of times, I have the options I listed up there ^ …and that’s it…
There are no sub menu’s in anything, I get into the menu, I can scroll + or - , If I press fire on any option it just puts me onto the next option in the menu…
I thought firmware was firmware…how can it not be there??..How can I have the only one that doesn’t have it in…
Tell you what, I’ll re install and see if it makes any difference.