ELR Home   Create recipe   Resource page   My recipes/favorites

What does "short" mean on my mod?


I have an ipv5 . I am using a TFV4 tank. I changed the coil. I am using fully charged batteries. My mod keeps sayong short. What does this mean. I am saving my pennies to get a whiterose mod but in the meantime. I NEED to vape. Please help me.


Your device is shorting out. Could be the batteries, could be the atomizer. My money is on you have a short in your coil. Just a guess of course but those 2 things would be the first things I’d check


Since you changed coil it might be that the new coil isn’t connecting properly because it isn’t screwed into place enough or it is just a bad coil. If you have more coils try to change to another coil and see if that helps.


My 510 connection is a little loose I tried to tightened but that didnt help either. I will try another coil.


Does the TFV4 have an adjustable 510 pin? Also, how tight are you cranking down on the coil when you install it? Maybe loosen the coil a 1/4 turn counter clockwise. If the 520 pin on the TFV4 has a slot for a screw driver maybe adjust it out a little.

The coil itself could be a possibility. Even if you just changed it, it could be a faulty coil.


Be sure that the leads aren’t too long and making contact w/the outside housing. Also be sure the coil isn’t bottomed out and making contact w/the deck


This may help, I don’t know



Usually for me it is the coil touching the inside of the enclosure or cap someplace. Pull the atty apart to where the coil is in the open and test it again on the mod just to see if it still indicates short. If it does not indicate short and gives you a reasonable resistance reading, figure out where it is touching another part of the atty.


An atty that does that all of the time for me is the Ammit single coil RTA. They put the posts real close to the inner housing and I can’t cut the ends close enough to keep it from shorting out. I always have to take a needle nose pliers and push the coil ends back into mounting holes.


Thank you. I adjusted the screw on the mod becaise it gets really loose like the connecter is going to fall out/ I put oin a new coil and it still says short .Maybe i got a bad batch of coils.


You should all know that she most probably is using a pre-fabricated factory coil not a RTA deck.
So there can’t be any leads touching the outer housing/chimney and they can’t touch the enclosure or cap.


If you have another tank try that on your mod to see what it says. Other than that i can’t really say what’s causing the issue for you without actually holding the stuff in my hand.

If another tank works fine you got a shorted out tfv4 for some reason. This can happen sometimes and they don’t last forever.

If you don’t have another tank you can go to a B&M and ask them if you could try one of their tanks on your mod to see if it works and maybe let them take a look at your tank to see if they can find whats causing your problem.

Anyhoo good luck


Yes i am using factory coils. I have a rda deck but im not to good at making coils. I think i got a bad batch of coils. I tried 5 coils and none work. I just tried my old coil and iit works.


Ok there you go. You might have gotten the wrong coils for your tank.
Hope you can find new coils fairly quick and keep on vaping.


Ok Now all of my automizesr say “short” or "check automizer. I thoink i need a new mod.


Ok so that is probably the 510 that has given up on your mod for some reason. If you know someone that is a bit handy that person could open up your mod to see if there is anything he/she could do with the 510. Attach a lose cable or tighten something perhaps.
Good luck, i hope you get it fixed.


Hey @robin I have an extra one of these in grey…it’s yours if you want it…no cost…your christmas gifts were more than enough :grinning: I’ll send it out. I believe I still have your address.


Such a nice thing to do. No wonder this is the nicest place to be on the internet :thumbsup:


This man rocks.

Also Robin I have several items I plan on paying forward. Mod wise I have 2 Fuchai 213s, one gunmetal and one blue. Just let me know.


There’s a chance a small piece of your thread could of come off into your 510, could only be a tiny slither of metal but I have had this and managed to get it out with a can of compressed air, try cleaning it out with a cotton bud (wooden end first) and some alcohol.
That’s if you’ve tried everything else, @MisterSinner has sorted you out anyways, because he’s a total legend, just thought it worth mentioning :wink: