ELR Home   Create recipe   Resource page   My recipes/favorites

Working Xcube 2 update software and Tutorial


Hola me señoras y señores!

So as most of us know, Smok’s new update tool (beta) doesn’t work for a lot of us and there has been tons of people smashing their heads against the wall trying to update/fix our firmware.

I have helped a dozen or so people by getting them the working (old) tool along with the hex files so that they may continue on with their lives :wink: So I thought I would make an official thread regarding the working software for anyone who is still having issues.

For whatever reason Smok removed the 100% working software from their site and basically are forcing them to use their new tool, that, from my observations, work for about 50% of us…I am not part of that 50% unfortunately…

I have firmware version 1.07-1.093 and the tool which will update you to whatever firmware you like

I have uploaded the files and I will update with new hex files as they become available

Please let me know if you have any issues!

Koopor and firmware updates

I don’t have this issue since I don’t have this mod, but what about uploading the files to something like a google drive or dropbox and just posting the link? That way you wouldn’t have to keep emailing/PMing with people. Just a thought.


short answer…I’m lazy :wink:


Ok ok you motivated me :wink:

Here is the tool and all the hex files but if anyone requires instructions or anything else PM me please



How cool is Darth? What a champion.


Not at problem at all, just keepin up my end of bein part of the fam :wink:

Also I decided to give a brief tutorial on how to use this tool since I’m getting asked, I could show you Smok’s but unless you can understand englishese, it can be a bit confusing for some


1 - Remove your batteries

2 - Open the tool

3 - While holding the fire button down plug your cube into the usb and then, while still holding down the fire button down

4 - Click “connect” on the tool - If it does not read connected, remove usb and repeat steps 3 & 4

5 - You may release the fire button once connected

6 - In the load File section click APROM

7 - Navigate to the folder you have the .hex files and make sure in the open file window that it is set for either to open “all files” or “hex” files because by default it is not and you will not see your hex files.

8 - Open the appropriate hex file - (Advanced users can alternatively copy the code in the hex files and cut and past directly into the tool)

OPTIONAL - This sometimes doesn’t work for people -

If you don’t want to erase your personal settings on the mod you can save them by clicking Setting under Configuration Bits and changing the DataFlash to 52.0 KB

9 - You must erase the previous firmware before installing the update by clicking “erase all” at the very bottom of the screen and then clicking “start”

10 - After erasing check APROM and Config under program

11 - Click Start and the new firmware should be complete!


Click Disconnect and remove from usb/replace batteries


soo cool of you to set this up some people are gonna really really appreciate thisbomb!!! you da bomb!!!


Ive already made use of this kind gentleman’s offer and my x cube’s working a treat, cheers @DarthVapor


Thanks guys, I’m really just lucky I held on to all my stuff, when I normally would of just deleted it after using it.

Hopefully they just get the new tool sorted and then we won’t have to bother using this one… but for now, I’m glad I could help!!


Alright, so I’m back with more frustration. My first X Cube 2 was a shit box aka DOA. Thing would always say short atomizer when I had a Ti build in even though it was in Temp-Ti mode.

I’m sending that one to Madvapes LLC for warranty, basically going to send me brand new unopened mod again which I will in turn sell.

I have since purchased another X Cube 2 because I love the mod and didn’t want to wait the 3 week process to get it back and use it again.

I have not updated it yet, it is still on 1.080 which is working for me at least, I can vape all my atomizers. The one issue here is that as reported, it reads the atomizer resistance 0.2-0.3 below what the actual value is. So I have to constantly adjust the initial resistance value in the settings.

My single coil crown works amazing once I adjust the resistance. It works like it should at TCoR of 0.00350, SC and vaping around 460. Weird thing here is, on my IPV4S I had the temp at almost 550 and I’m getting the same vape from the XCube2 at 460.

My dual coils is where it gets weird… On my IPVD2 my Billow v2 never gets hot in the slightest bit. I can chuck 10 fat clouds and it still feels cool. I vape at 460 and 50J on the IPVD2. The same Billow v2 on the XCube2 I have to have the temp all the way up to about 500 for it to vape. Might I add, after some tinkering I figured out that I can set the DC option to 0.00175, but as I said the temp must be around 500 for me to get the plentiful vape I was getting at 460 on the IPVD2. When I set this up on the XCube2 as mentioned, the Billow v2 gets extremely hot, I mean I’ve never felt my Billow v2 get this hot… I’m lost for words as to why this happens??

To say the least, I’m hesitant about upgrading to 1.093 because of the issues I have read about the mod not connecting to the app anymore. My last issue is the app itself, I had to downgrade to v2.4.3 of the app for me to be able to log into my account. When I login on the v2.5.1 it crashes every single time. It did this on every version of the app until I finally got to 2.4.3 which worked for me. I logged in, didn’t recognize my account so I had to purchase the $0.49 Ti again.

Wondering what you guys think about this. Should I upgrade the mod and then again the app to v2.5.1 and see if it all functions on the newest software and app software? I can always downgrade to what I am running now.

@Pro_Vapes tagging you so you can see my progress and maybe think about this yourself


I have nothing left to say about that mod, app or update. My latest one is a paperweight. I can’t figure it out. Maybe someone with a working mod can help you.


Why don’t you ship it to Madvapes LLC for a warranty? They will ship you out a brand new one.


Unfortunately @ryan8five0 I cannot help you with the app, I have never gotten the damn thing to work and outside of unlocking titanium and stainless there is no point in me even using it and I am on Android.
Supposedly the 1.093 fixes those differences you speak of and more…
Outside of people saying it fixed theirs, like @Pattie and others, I cannot verify this because both of my cubes work and thankfully I haven’t had any issues outside of using the app when I first tried it.
All I can really say is try updating to the new firmware and if you have any problems or more problems than you already have you can roll back to the previous versions using this update software I posted?


@ryan8five0 I’ve updated to 1.093 and it solved most of the problems i had with mine. @DarthVapor helped me with some files and from that i could update. I say most of the problems, I’ve found a few things like, it still jumps like a strobe light in tc mode with a ti dc build in the rba, even a sc in ti I’ve had to fiddle with the TCoR and temp to get a decent toke.
The app on ios works fine & on my mod, changing settings no problem to the mod, got straight through to re activate ti & ss, but realy i find myself playing with setting’s and fiddling about to get a decent vape. REALY!?!
There comes a point…


I’ll go ahead and report back later when I get home from class and update to 1.093 and see how it functions then.

I also noticed another weird thing about resistances. My IPV4S reads my billow build at 0.09Ω and my IPVD2 reads it at 0.8Ω. My single crown build was 0.130Ω on my IPV4S and on the IPVD2 it reads 0.112Ω. My ohm reader reads the billow build at 0.12Ω and my crown build at 0.16Ω.

I have no idea which one is more ‘truer’ than the other. Which one would you adjust the resistance to on the Xcube2 based on what I posted above? I’m thinking if I take the average between the IPV4s and the IPVD2 resistances, that is what I should set the resistance to on the XCube2.


That’s what I would do or be safe and use the higher?


I set it to my IPV4S builds resistance and I’m getting a decent/nice vape.

Another thought; I could put my build into steam-engine and see what the value of the resistance there is, but I’ve never had much luck with getting the info from steam-engine and actually replicating it to a build.

Do you think the fluctuation of the different resistances is simply from the internals of the devices used to measure? Surely there couldn’t be that much internal difference to give me a 0.9Ω build on my IPV4S and it comes out to 0.12Ω…


I would think like you on that one just split the difference between the high and low and it wont be that far off.
Let me know how you get on abd if i can help in any way i will. No problem. :+1:


My experience with steam is almost nonexistent… but I would still do the difference/average of what you have now?


Grr, now the XCube2 reads my crown build at 0.148Ω lol. This thing man

Split the difference of IPV4S and IPVD2 and set it at 0.12Ω at 490 and I’m getting a plentiful and wonderful vape of my SinaMilk, so yummy.

Even for an advanced tinkerer like myself this becomes mind boggling at some point. I feel bad for first timers that got this mod and had to do the run around with it.