ELR Home   Create recipe   Resource page   My recipes/favorites

Working Xcube 2 update software and Tutorial


Theres many a man (& woman) have spent many an hour or 5 on the “puzzle of the cube”. Enjoy😄


Perhaps this mod should have been named Rubic’s Cube. Sounds just a bit more appropriate…


That sounds about right mate. Ha.


Hey everybody, just got my xcube 2 I have the app on my phone,took the batteries out to charge them and put them back in and when I hit the fire button and it’s saying max puffs and I can’t vape or anything please help


Did you use the app at any time before this or change any settings via the app?


Do this with the fire button.

3 quick clicks takes you to the menu
3 quick clicks takes you to puff counter
1 long click (press and hold) to enter puff counter menu

It should say this…

Then a number, 0 - whatever.

This happened to me once. I went into this menu, clicked the + button (where you change watts, etc) and the word NEVER changed to 1. Then click - and it went back to NEVER. Then long click the fire button. It will ask if you want to reset the puff counter. Just click the minus button again to go from 1 to NEVER. Then long click again.

When I did this it worked for me. Let us know if that fixes it.


i tried this , its saying aproms size is too large ?


I hate smok . Mod wont even boot up now .


Things with this mod started out very promising, but now Smok is putting out garbage. Those of you with a working smok mod are very lucky. I hope these problems don’t transfer to the Kooper. I love the TFV4… but I will never buy another Smok mod. There should be a recall on these or at least an update that address and fix these issues. Where is customer support? Smok has taken a giant dump on the vaping community.


I should have never tried to update it . Hopefully it can be saved some how


your mod has a 6 month warranty on it. Send it to madvapes if the problem persists. They’ll ship you out a new one.


I’m trying to get a refund from Efun. It arrived broken and the refund policy should cover it. I’ve done all they ask me to do (make a video for proof). If it fail I’m filing a claim with PayPal. If that fails, I’ll send it to Madvapes. I really don’t want a replacement, but it’ll be better than nothing at all. All this is a huge PITA. At the rate these black xcubes are failing, I’m thinking Smok will be replacing 50% of all they sold. I fairly certain they knew these mods were bad when they boxed and shipped them in the first place.


The firmware is basically identical - a tiny difference in how the menu is made, but otherwise its the same. With Koopor everything is enabled though, so no activating stuff.


I have never seen a Aprom too large error? You erased the previous firmware and started with a wiped mod?
Im sorry I’ve never seen that nor know how it is possible? Did you erase it again and start a new update?
What firmware did you haveand what firmware said “too large”? The only thing I found on that error is trying to install over existing APROM but if you erased the previous 100% you shouldn’t get that?


One of my update said no data, and another said data too large. I had it set for 52 kb.


How very odd…Im at work so I cant run it atm but I would suggest skipping the step were you change the value to 52k or make sure all your other values are set per picture above?

There’s a value somewhere that doesn’t match up if you are getting that error?
Probably a lot easier to just skip that step entirely since it isn’t required and sometimes doesnt even save people’s personal settings in the first place.

I’ll look into it when I get home…

Sorry about that, now I feel partially to blame because I added that step but it is now obvious that every cube is NOT created equal…


So I hit erase all , then I imported the 1.93 update i had the 1 .08 or whatever and then it hit aprom and config and that’s what it says . Is there any other way I can completely wipe the mod ?


Ok I’m not sure I fully follow what and when you are getting an error.
So you connect the mod
Click both “Erase all” and check “Config” then press start.

Does the green bar at the bottom say successful? Assuming it does, you click APROM to load the .Hex file and before you press start, both “aprom” and “config” are checked at the bottom?

Couple more questions- What does it say in your Configuration bits area? also what does the drop down bar say? “last config” or “on chip config”?

Erasing all with on chip config will reset back to default and you may have an error in your “last config” but I need more info, something doesn’t make sense and if you successfully erased it and then loaded any hex files it should quickly install it.


I’m at work but I’ll bring ya through my steps when I get home . Appreciate your help though


So I connect the mod hit erase all …it won’t let me hit config with the erase all on . I hit start it says PASS then I load the 1.93 hex hit aprom and config and hit start then it says Aprom size is too big