Berserker Mini losing juice flow

I have a VandyVape Berserker Mini tank that is over a year old. It has worked fine through several re-coils, re-wicks, and different juices. But now, the juice has stopped flowing. I fill it up and vape 10% to 20% of the juice OK. Then, with the tank still 80% full I get a dry hit. I take it apart to inspect and sure enough, the wick is dry.

I put it back together and let it set for while, then re-inspect the wick. Now it’s juiced and vapes OK. But only for a while, then the wick goes dry again with the tank still 50% to 70% full. Looks like there is some kind of vacuum happening that prevents juice flow. Removing the bottom coil deck releases the vacuum for a while. So I’m baffled, any ideas?


Have you checked the integrity and placement of your o-rings?


The original Aspire Cleito suffered from vapor-lock as well. Mildly so with 70vg, and pretty badly with 80vg or higher. So much so, that I had to crack the top cap open after every fourth or fifth draw.

It’s worth noting though, my issue was a compound problem. I take long draws, like 7-10 seconds. Certain tanks/cartridges just CAN NOT keep up. Add in higher VG, and it’s a recipe for frustration.

As long as you don’t have any PG issues, you can always try a less viscous liquid (lower than 80vg). If you’re already using 60vg/40, or lower… Then perhaps the coils are from a bad batch?

Hard to say, but hope it helps somewhat!


Thanks. There is only one o-ring and it looks OK. All my juices are DIY at 50/50 PG/VG ratio. Since this started happening I’ve changed juices twice, coils 3 times, and wicks 5 times.

Coils were all made at the same time from the same K30 wire. How could a bad coil stop juice flow?


Overstuffing the cotton for starters…
Too much cotton and it won’t feed properly.
It only takes one time to singe the cotton in a pre-built cartridge and the taste is ruined from them on.


Hi there Redcrown !

I have 4 of these and use them daily for my NET MTL vaping. I find them an excellent performer and design .

Possibly your issue is with damming up the small 2mm juice port flow hole with excessive cotton?.

Because the design is a floating deck, it is not possible that the juice is not flowing to that port area. The way the deck design works is that Gravity flows the juice to the below deck area, there are no positive or negative pressures (vacuum) involved in the process. This assumes normal use where the atty is held in a vertical position in relation to gravity. I suppose that if you turned the atty “upside down” and held it there, but I am sure you are not doing that !!! - :grinning:

See my photos here and note that a successful wick is not more than 22.0mm total length with a V-Cut Trim at the end of each end of the wick. Gently nudge the wick tip to the 2.0mm Port Opening, Do not “stuff it”

PS: Of course you are soaking (with gentle agitation) the dis-assembled atty during your re-wicking in a coffee cup full of hot clean water?


I just read your response to another poster and your comment is incorrect. The design has 3 O-Rings. Please completely disassemble your atty and observe it carefully for its design, A good time to do that is as you soak all parts in that very warm(almost hot) cup of clean water…Thanks.


Are you doing something different then when you first started using it? Like pre-satuating the wicks before filling the tank? and then you stopped pre-soaking the wicks and just filled it and let it sit? That’s the only thing I can think that might have changed the way it flows or would change the vacuum inside.

Let me know if you changed how you initially wicked it up and juiced it up. Im getting a similar tank soon with a floating deck. Hate to rub into something like your experiencing.


Thanks again for the help.

I took the thing completely apart. Soaked and washed and even gave the parts 20 min in my ultrasonic. Replaced all the o-rings (even though they all looked good), rewicked. Now it’s been vaping OK for about 2 mils of juice. Probably too early to tell for sure.

When I first got the Berserker it leaked a lot through the air hole. I read a tip somewhere to bottom fill the tank instead of top fill. Theory being that the tank gets pressurized when you replace the top cap. That worked, I’ve had zero leaking since using bottom fill.

When I took it apart now I had a lot of trouble getting that top-fill cap off. That sucker was welded on. It had not been off in a few months, although I wash the tank in hot water frequently. And when I put it back together now, the air flow control ring was very stiff. Could barely move it. But after sitting for a day that ring now moves normally.

I wick pretty much as shown above. I don’t think I was blocking any holes. I always prime new wicks. The unit is in rotation with 5 other mods (different juices). Sometimes it might not get used for a few days. I’m wondering if that had something to do with it. The Berserker is my favorite for overall vape quality.


@50YearsOfCigars That is a GREAT tutorial.


Yes it was. i dont have one but have similar “damn it, damn it” One thing u can do in case u block the hole is poke it w/ a wire/pin to clear it up.