Calling all ELR electrical wizards - yet another mod problem

hey again, as the electrical gremlins continue to haunt me I have an issue with my RX200 now that is driving me potty, I shall describe the symptoms and see if any of you doctors know the score with it and as a long shot…know the cure…

it works ok, then after a short while the battery bar starts to flash as if it is charging, a short while after that it reads the batteries as flat and refuses to work, then it locks itself, occasionally just goes off and doesn’t come back on, so I take the batteries out, leave it an hour or so and put them back in, all fine again, the batteries all read within .1v of each other, then it starts again, when the battery bar flashes the battery readings are all over the place. I have tried different batteries, all married, same outcome, If I just take the batts out and put them straight back in it doesn’t change anything, it’s almost as if it needs to cool down but it doesn’t get hot.

any clues before I launch this thing at the nearest solid inanimate object…??

1 Like

I don’t have one but think I remember seeing this issue before on here , perhaps it was in this thread.It may have been @Big_Benny_MI or @sillyrabbit that had that issue.
Wismec Reuleaux RX200 Horror Reports


Please, for the love of God… throw it at the nearest inanimate object and buy a new mod! It’s not worth catching your face on fire!


I don’t have one, but try and do a firmware update. Might fix the issue.


yeah I’ve just read all that, thanks for the link, I have scoured the tinterwebz looking for people with similar issues, I have this morning charged the compressor up and give it a blast through with the air gun, left a while, now it just says ‘Atomizer short’ with everything…on the plus side the battery bar and volts seem stable :neutral_face:
I think it is dead…6 months, didn’t they used to last longer…? :disappointed:


initially I thought inanimate…
but now it just may be the next person to ask me what the f&*k im doing still pissing around with that ‘e cigarette’

after many many tries I actually succeeded in updating to the latest firmware, didn’t make any difference though :disappointed:

Guaranteed there is a small shaving of metal down the side of your 510 pin or liquid has got to a cable.

I had that atomizer short on my eleaf 30w and found lots of little bits of metal around the 510, it was a real pain in the ass to clean out as the 510 is a sealed unit, lots of pressing and blowing and scooping etc


I have a Tesla Lipo that started acting up at 6 Months.

1 Like

Yep, most mods have those drain chambers on them. Liquid can even get in the USB plug…I take the batteries out and put them in the window when the sun is beating down on top of a paper towel. I usually find a little puddle or mark…

1 Like

You put your battery’s in direct sunlight???

I’ve now had the hot air gun on it and am leaving it to air for a bit, I’ll have a closer look at the 510 this afternoon…


With a hard wired lipo in a case, yes. In a mod with 18650’s no… I take the batteries out… I don’t leave it there very long…You gotta warm it up so the liquid thins and comes out of the mod…e-cig liquid doesn’t evaporate.


Thanks, I thought you were just sitting them in the sun lol battery’s go bang if you leave them too long

1 Like

No no no no…:stuck_out_tongue_winking_eye:


give the 510 a wipe with a qtip and isopropyl alcohol that fixed my atomiser short issue and it jumping out of temp control


I get atomizer short on a few tanks ive had on other mods, not a rx200 tho but its always just rubbing alcohol and qtips solved it.


also do you charge your batteries in an external charger or do you charge them in the rx200?

1 Like

external, always external, and always married :+1: currently got the thing in bits and cleaning with some IPA :+1:


Contrary to the opinions of some, canned air (or using air compressors and the like) may temporarily fix problems, and once in a blue moon (when exceedingly lucky) even permanently. But more often than not, that air pressure only make problems worse, by taking the liquid (most common culprit) and sending it into critical areas that it might not have reached yet, turning what might have been a salvageable situation into a permanent landfill item. Best advice, don’t use air unless you’re blowing dust out.

Given you’ve already tried different sets of batteries and gotten the same results, you can rule out batteries.

Given you’ve already tried to update the firmware, and have the same results, you can rule out firmware.

That leaves one thing. It’s without a doubt a hardware related issue. Now, that’s still very open ended, but…

  • the wiring: you could have a (non-visibly) “pinched” wire, that makes solid enough connection while in a “cool-state” and only rears it’s head once it’s gotten to a certain wire temp, or past a certain amount of current. OR, you could also possibly have a cold solder joint. Normally indicated by small circles, but sometimes visible as “ripples” within the solder itself. Google “cold solder joint” images for examples. Reflow any questionable joints.

  • (as mentioned above) You could also have debris in your 510 connector path. Easily handled with a Q-tip, some isopropyl alcohol, and possibly a magnifying glass and some tweezers.

The more complex…

Now, outside looking in (judging by written description) it sounds more like there’s a problem with one (possibly more) of the ic’s onboard.

Possibilities include:

  • the power ic (which should handle any regulatory functions, and usually charging duties as well, and naturally the “b+ feed” to the main ic.)

  • the main ic

Either way, when I find such symptoms, and do a search, then see lots of failed reports with almost identical descriptions, my first thought is one of two things. Flawed design, or faulty manufacturing process. Either way, the next question is then "is it under warranty. If yes, no canned air, no opened screws, pass go and proceed directly to the vendor or manufacturer. :wink:

Will continue to watch with interest

EDIT: auto-correct, and clarifying thought on a small aspect