Wismec Reuleaux RX200 Horror Reports

I have watched a number of Youtube videos. read alot of reviews on the said Mod
all seem good, untill i get on the forums all I seem to be reading is horror stories, but this failing, that failing,
batteries not lasting as long as reported, not sure if this mainly down to the user using crap batteries in the first place. but wont rule that out.

Even after the update, there seems to be issues with the wattage, temp control modes,
i starting to think there are a lot of bugs with the board that haven’t been ironed out before release

and who got a bogus/faulty one…

The answers will determine whether i go out and spend the £40 on a MOD

PLEASE SELECT YOUR VOTE CAREFULLY

  • YES I BROUGHT ONE FULLY WORKING WITH NO ISSUES
  • I BROUGHT A RX200, HAD A FEW ISSUES WITH IT, BUT ALL WORKING 100%
  • YES I BROUGHT ONE, BUT HAD NOTHING BUT PROBLEMS, SENT IT BACK, AND WONT BE BUYING ANOTHER, NOT WORTH THE MONEY

0 voters

2 Likes

I use mine every day. Absolutely no problems after I learned how to use it properly.
I typically drip too with SS @ .15 Ohms 60w 400-450F
Only use 3 married batteries… ever.

1 Like

To do a poll you do

[poll]
 - Option One
 - Option Two
 - Option Three
[/poll]
4 Likes

Thanks JOJO… i will do re-edit the post now

xx

I’ve had mine sense Christmas and haven’t had one bit of trouble with this mod. I use it every day. Along with my wismec dna200. Either mod has had issue one. I’ve heard you can’t use the tfv4 either. And I use that on both mods everyday. I use HE2s in both mods. Bat life is about a day and a half in both. And I’m a heavy vapor. It’s like anything out there. Your going to get good and bad.
Would i buy another one. Hell yes I would hands down.
Hope this helps you in your decision Thx ribbit

4 Likes

I got mine in January and had no problems, I use sony vtc4’s two pairs of three just for this mod, I was using the tfv4 but did not like the weight, but now have the Aspire Cleito 0.4 Ohms on it now and it great. I do see a lot of people with them now due to the low price of this mod. Good value for money.

2 Likes

Use mine daily with rda’s rta’s and rdta’s. Not one single issue. (Touch wood)
Exelent all round mod. Would not hesitate to recommend.
Battery life exelent and i vape with low builds. Typically 0.06-0.12.
Edit:- i use lg he 4’s in mine.

2 Likes

My Wife and I both have RX200’s. I bought hers on a pre-order deal and I eventually bought one a couple of weeks ago. She uses hers everyday and has had no issues. I use mine for a little while every few days and again no issues. We both use sets of LG HG2 batteries.

3 Likes

Thank you all for the votes so far,

I am wondering, does the RX200 send a 30watts pulse when changing temp modes like the pegasus does.
recently i have just stated to get a burnt hit from my 0.5ohm coil… it was primed correctly before installing.
but i think i know where the issue lies with this,… i had had been changing flavors and ratio with it.
going from 50/50 to 70/30. so i think i am to blame for this one…

Q: One 0.25ohm… i persume is a kanthal build ?? i sort of knew my pegasus would thought it into TC mode with it being a SS coil… started working fine in wattage mode for a little while i got it wicking… but now it reads LOW RESISTANCE … and wont work in either wattage mode or TC mode … any idea’s ??

Bought mine at Xmas time. only getting a day - day1/2 max out of HG2’s :confused: otherwise, no issues.
EDIT: running a Billow V2 0.19 @ 70w & a magma 1.4micro @ 12w

Thing to be cautious about with reading complaint forums too is most people don’t post when their issue was fixed or when it was just simple user error.

I’ve had the RX200 for a few months now. Every now and then my batteries discharge unevenly, but that’s my only complaint. I don’t think it’s the equal of the DNA200 Reuleaux, but for the money it’s a great package.

1 Like

How do you know they’re doing that - what are the signs?
…Praps thats what mine’s doing

Every now and then my mod will show low battery and refuse to fire even when the battery gauge is at 75-80%. If I pull the batteries out and put them on my charger it might show as much as .2 volts difference in them. When this happens, if I pull the batteries out and rearrange them it works again.

I’ve tried this with 3 different sets of married batteries. All have only been charged on an external charger. Same charger I use for all my other mods with no problem. I have to believe it’s in the mod. Doesn’t happen often enough to quit using the mod, but when it does it is annoying.

Yeah i can believe that would be rather annoying, I will take note of this is case i get a RX200 and it happens to me, hopefully it won’t but who knows

i need to invest in another external charger, the only one i have is a humble single 18650 efest one…
rather annoying when i have about 4 batteries to charge up at once

well got my birthday coming next month, so i will stick that on my wish list
fingures crossed lol…

1 Like

Thx for that @Big_Benny_MI!
Na… mines def not doin that! But I’ll keep your fix in mind in case it ever does.

I’d still recommend the mod. I should’ve probably sent it back for replacement, but it honestly only happens now and then.

If you get one they have two new colors coming out. The red on black one looks awesome!

Hmm… well this is interesting… I’ve just swapped over to the magma (with the build described above) from the Billow. I’ve taken 6-7 pulls and it’s stopped working- telling me “devise too hot”. Yep its hot!. It was warm when I did the swap, but this is normal because I’m swapping them all the time. Its the first time its done this. I’m guessing its a coil issue? - anyone got a better idea? I’ll re-coil the Magma later when I’ve got time & report, but in the meantime, any thoughts on this would be appreciated.
N.B… I swapped back to the billow after it had cooled off & have been on that for the last 10 min & the mod is only mildly warm.

For $40 I think I will give this a shot! Mod technology has really come a long way since I started vaping. There are a lot of really nice, high-tech devices for under $50 these days.

Mine works fine and fires until the batteries are basically empty, but there is always one battery that is fully charged before the others are. I should get my lazy ass together and take note of where in the mod that battery was. It has nothing to do with where they are in the charger. I’ve only had some issues with this mod the first day I got it, but it might have had something to do with the thing being stone cold after shipping. The next day at room temp it worked like a charm and has done ever since. It might not be as good as the DNA version, I wouldn’t know cause I don’t have one, but for the price it is a great mod. Mind you, I’ve read quite a few posts about issues with the DNA too and after forking over that amount of money, that really sucks :scream:

I finally got one last night. Been using it hard ever since and no problems whatsoever. Running the TFV4 with dual RBA - twin 22ga Ti running in TC. I did try wattage mode today with a Velocity using dual Claptons. Worked great with that too. The one thing I will say after having used the DNA 200’s for the last 4 months, and that is the preheat feature of the DNA boards makes a very noticeable difference in the TC experience. That 1 second at 90-100 watts just gives a much nicer vape from the second the fire button is pressed.

2 Likes