Cuboid 510 fix

Hello all. I ran across a reply on a YouTube video that was ignored by everyone, I decided to try it. What do you know … it worked. If you have a Cuboid, or other Joy tech 510 that is reading atomizer short try this simple fix.

  1. Five click to turn mod off.
    2.Hold the fire button in, do not release it.
  2. Open the battery door, still holding the fire button.
  3. Close the battery door still holding the fire button.
  4. Look at the screen, it should read something for ohms.
  5. Release the fire button only when you see a ohm reading.
    You might need to turn the mod off, and back on to get a correct ohm reading.
    This returned my bricked mod back to working order. I am not exactly sure why, but it seems to be some kind of reset. Maybe all those 510 problems, are not 510 problems. This seems to be a problem within the board. Try it, let me know if it works for you.

Dude?! @Oleskool1 You just fixed my original bricked Cuboid. I’ll let ya know if it keeps working or not THANKS!

1 Like

You forgot to mention throwing it on the floor and stomping it into tiny pieces with your steel toed boots. That does the trick too!


Well actually it’s the stainless steel model and I think you might be able to drive over it
… still funny


Glad it worked for you too.

1 Like

i am following

I would like to see how many people this works for. I would also like to see what the experts say about why it works.

Just saw what you posted @LordVapor. Lol, that is about where I was with this before I read that YouTube reply. I was using a couple older single battery mods until my new model arrives. Now i’my back to the cuboid. Strangely with all the problems others are having my cuboid is almost 2yrs old, and just now giving me problems. Even that is fixed for now. I only paid 29.99 delivered for it. That was a sale though. It has served me well for that price.

1 Like

It worked! I was just getting ready to desolder the 510 connection to see if I could make a fix to the fitting. Had ss316 in the atty and started it in wattage mode. Don’t know if it will be stable in temperature mode yet,going to vape like this for a while then try on a cold coil. Haven’t used the one in two months and have had apart twice.You da man lol

reporting back… I have had to do this about daily, but have been totally using the same trick which works every time within like 10 seconds. Obviously this is some kind of reset to the detection function on the board. My Cuboid too is one of my oldest mods

I loaded the Arctic Fox firmware on my Cuboid and all of the 510 issues went away. This firmware is awesome. It add much more control to pretty much all Joyetech, Eleaf and Wismec mods. It allows you to set up and monitor the performance of your mod from your computer as well.

I am running it on the the Cuboid, Cuboid Mini, VTC Mini and RX200s.

Ceck it out.


@louiesquared I need to look that over when I have time. Looks good. Glad this is working for people. If this gets out it may lead to a firmware fix. Article fox seems to be a jailbreak of the firmware. I hate to do that, but I will.

It’s not really a jail break. You can easily revert to the stock firmware at any time.

Nice bit of software. I like all the customization that can be done and you get a clock display to boot! I’m running it on an RX 2/3, Cuboid and Istick 100W TC. All are working great! Just wish there were some easy to understand instructions for the more advanced settings. Thanks for the post!


Awesome bit of software it actually made one of my rx 2/3 work as it is meant to. Great find @louiesquared thanks a bunch.
Anyone who has an rx 2/3 that throws a hissy fit with some wire (316l in particular) should install this firmware it is most definitely a massive improvement.


yup. Fixed mine right up. No more “wtf is wrong with this thing”