ELR Home   Create recipe   Resource page   My recipes/favorites

DNA 75C constantly going into Temp. Protect, anyone else?


#25

If temp protect means that the board is overheating, it’s probably a problem with the board, broken sensor or something. I’d get indeed in touch with Evolv.


#26

Dman did you reset to defaults or hard reboot?

tools>diagnostic>reboot device>hard reboot

The hard reboot is an absolute reset to the defaults (including i believe firmware)


#27

I completely agree! It’s probably the mod he dropped 20ft.


#28

That’s what I’m thinking too. Even though I’m NOT vaping in TC, there ARE still temp sensors in play, and it’s like whichever one is causing the error must be bad, thinking the board is overheating even though it’s not even warmed up yet.


#29

Hehe, not THAT one Cut.


#30

So the board reads temp even though its in Watts mode?? :thinking: Why?


#31

Let me hook it up to the lappie, all I remembered was factory defaults, let me check/re-check.


#32

most mods have a temperature protection so it doesn’t damage the electronics on the board… just like overheating protection on a CPU or GPU in a computer


#33

The board had a temp sensor on it as well, for charging lipos and for chain vaping.


#34

@anon45050679 I think what’s going on, is there is a temp sensor, somewhere, maybe to protect the board, who knows, but wherever it is, it’s NOT seeing coil temp, because the coil never even heats up, it’s like a self protection temp sensor, that’s bad (I think) and it THINKS the board is overheating, when it’s not.


#35

open it up, do you see one? :wink:


#36

I’m pretty careful with my expensive mods, and they NEVER get juice in them, basically ever, so I’ll re-check inside, but I run a tight ship, and can pretty much rule out anything shorting out the board from a user error standpoint.


#37

E-liquid should not be conductive… otherwise your coils should be shorting out constantly


#38

That’s going to take some work, most are micro chips, not an obvious sensor per se. I’m trying to find my USB for Escribe now.


#39

But can still destroy mods once inside…


#40

That’s what I thought, but I actually HAD that issue with one of my Whiterose mods, and he told me to check, and in THAT case I actually did have some juice on the PWM board. Cleaned/dried, problem solved.


#41

I’ll take your word for it, I’ve never had the pleasure to experience it


#42

Why are you crazy facing your own posts?


#43

Ok, here you go peeps. Clearly in wattage mode, 0.5 ish ohms 40 watts, different tank, in protect


#44

just so you know, the “temp protect” message isn’t an error. it purpose is to let you know that you’ve reached your set temp and the dna board is adjusting wattage to maintain and not go over that set temp. i have that message turned off

Can you turn that off in escribe?