ELR Home   Create recipe   Resource page   My recipes/favorites

DNA 75C constantly going into Temp. Protect, anyone else?


#45

Yes, turned it off, same error, turned on to 600 degrees just to see, same error.

I get what you’re saying about error vs. legitimate threshold protection, but in my case it appears to be in error.


#46

Just clutching at straws really…

Make sure your coil legs are tight in the posts, no play at all, check that there isn’t a stray wire clipping hanging around on your deck somewhere, and make sure the coils aren’t touching anything they shouldn’t be.


#47

If you don’t want to open the device yourself to have a look, I’d try the hard reboot and if that doesn’t work, get in contact with Evolv. They’ll be best positioned to help you.


#48

Sacrifice a smok mod to the vape gods (although that probably wouldn’t satisfy them at all)


#49

I would try to help you further but this place has trolls… :laughing:

Edit: and perverts @Cutlass92 :rofl: :fu:


#50

Lol that’s all I got at this point. I have tried 6 different tanks, all with the same results. All have .3 - .5 ohm builds, all right, and do work on all other modes, including 2 DNA250 mods. Everything points back to the 75c as the trouble. May tear apart tonight, but have to be up in 5 hours, so might blow it off.

I do appreciate everyone’s help.


#51

The “temp” can be set, even in wattage mode, via mod or escribe. Tested maxed at 600 … no joy…


#52

@Suomynona Well I didn’t believe it. Only had that Whiterose for a few months, started acting up, display was getting wonky, emailed WR and he knew just what to check, and sure enough (I don’t know how it happened) but on the back of the PWM board, there was some juice. If I hadn’t have witnessed it first hand, I wouldn’t have believed it.


#53

Only had 2 mods die through juice leakage… Can’t be liquid though! :laughing:


#54

Even though you all thought I WAS vaping (or trying to) in TC with Kanthal, I know the love is still strong here !!!


#56

Well let me clarify, as you guys ARE trying to work this with me. The unit is NOT switching modes. It’s in wattage mode, never leaves, never changes. You can see the screenshot above. While IN wattage mode, and trying to fire it, it just goes right into temp. protect. Let go of the fire button, the temp. protect clears, and it’s right where I left it, in wattage mode.


#57

Thank you, but I DO have my days…


#58

Not help to the topic since I knew you weren’t.

But despite the kanthal can’t be vaped in tc comment goes, the solution is hohm wrecker g2 and then you could vape ka1 in tc mode!

With that out of the way, let’s find a solution for the dna mod! :wink:


#61

LOL @anon45050679, +1 @eStorm

Here ya go, just as much of a mystery after checking escribe as before. Wattage mode, profile 1, etc, etc…


#62

Turn off Punch and locked


#63


#64

Punch off, lock off, 55w.


#66

Omg it’s firing !!!

I have no clue. Maybe the 2nd factory default ??? !!!


#67

Yeah, probably


#68

Good job you nasty boy!