Dry Coil - No Liquid - Dual Ti Build on Velocity

I have a dual Ti build in a Velocity using 24awg Ti 1. 7.5 wraps. Clocking in at .093 ohm. I keep getting my iPV 3 Li shutting down on me saying no liquid, even after juicing it up. It does the same thing on my iPP D2. What gives? Please help. This Ti wire is starting to leave a very bad taste in my mouth as far as ease of use. I am ready to switch back to my trusty claptons.


[quote=“LordVapor, post:1, topic:36322”]
Clocking in at .93 ohm.
[/quote]You have a bad connection or something’s not reading correctly. There is no way that build should read .93 ohms…

If you can get the correct res locked in it should work. Your mod is pushing all the power it has to ramp up that coil at that ohm setting.

This is the settings I used…

Everything is tight.

My bad. Silly typos. .093 ohm

I don’t know what your problem can be. I have a similar build and there are no issues. For some reason some members have considerable problems setting up Ti wire. If you rule a equipment malfunction then it must be in the wire. There are a lot of people now that use Ti so I know the wire isn’t the blame if you got it from a reliable vendor. That only leave some type of user error. It’s very hard to pinpoint a problem without all your factors being posted including wire brand and a pic or two.

1 Like

Try a 3mm ID instead of the 2mm. You are most likely cutting off juice to the center coil wraps.


The coils are plenty wet.

The wire was purchased through Etsy. It’s the jewelry supply @SthrnMixer posted in your Ti thread @Pro_Vapes. I will post some pics here in a few…

1 Like

That only leave the 3rd option.

I missed this in your initial post.

I made plenty mistakes learning how to setup Ti builds. It’s nothing like Kanthal and it burns much hotter. Fast wicking is a must with Ti.

Once you get it right it will be worth the learning curve.

1 Like

I don’t want to twist your arm to make you listen so maybe I can explain a little better. The cotton inside the wraps is most likely dry, especially near the center. The exposed cotton can be drenched and still inside the coil be dry as a bone cause it is too compressed to soak juice in fast enough. I believe this will solve your problem so at least give it a try…

1 Like

I sure will. But even after pouring juice on it says no juice. So I will try 6.5 wraps around a 3mm rod. Does that sound about right? The steam engine says that should be .2 ohm. But every time I wrap a coil using that it comes out lower. .2 = .093


I should add that I have 4 Ti builds working perfectly in my tanks. But this is my 3rd attempt on the Velocity, and the only RDA I have tried to build on. Looking at the pic you can see it is wicking really good. But I am building a couple 3mm coils right now.

everytime I build less than 8 wraps It comes out under .1 ohm.

This came out to .109 on my iPV D2

Now it’s not saying no liquid. But I am getting very minimal vapor production. Almost as if it is only barely heating up at the 330 degrees I run at with my tanks. So I cranked it to 450 and now it’s working. Any thoughts why I have to run this build at a higher temp to get any vapor?

The boiling point for PG is 370.8F and the boiling point of VG is 554F. Mix the two together and of course the boiling point would be somewhere between those figures. This is why your now correctly functioning build will not produce vapor at 330 degrees…

PS: I swear that picture makes that wire look thicker than 24g…

I broke out my IPV4 and took a couple pics. I did this build last week. 22g Ti, 3mm ID, .073 ohms. This is how I set up with no issues on any mods I own…

Just hang in there… when you figure it out it will be well worth it.

1 Like

The number of wraps is per coil. See if I plug in 0.093ohms it says 7.5 wraps, right?

Thanks guys. I will keep at it.