Smok Alien 1.3.2 Firmware Update

Seems Smok kept this one a bit quiet.

Anyway I’ve tried it out and it’s cool, it remembers your last coil ohms, detects a change when you install a new Coil and you can choose new or old, the Ohm resistance is also a bit more accurate: grab it here:

New link thanks @Gambit117

Old link (now dead)

Make sure your updating the correct version for your Alien.

This firmware is only for V1.X.X version Alien mod. The A version, the B version has a different update.

Have fun

Shane :slight_smile:


Awesome - thanks for the share petal :+1:

1 Like

Hi @Lolly my pleasure :grinning:, glad to be of assistance :+1:

1 Like

Thanx as wel @Shane18


Your very welcome @chux72vette :grinning:

Here’s why the 1.3.2 update makes your Alien even better…

You been using a tank, your coil is burnt out or you just wanna change tanks.

Wait, your Alien is hot so your ohms will not read correctly, do you wait for it to cool down?

Not anymore, screw on your new tank and if the ohms that are reading at the new setting are correct, simply choose new and vape on!

If your ohms are reading too high, for example I know my coil is 0.3 ohms either stock as it says on the coil and the side of the box or just read from an ohm reader if you just rebuilt.

So you screw your new tank on and your Alien says 0.398, crap!..


Now it’s simple to trick your Alien into taking your ohms down below the amount allowed by adjusting your ohms in settings.

Simple choose new, you now have a read out of 0.398. Go into settings and into Adjust Ohms, take your ohms down or up to the max allowed ±0.030.

Hold your fire bar to save, you now have a readout of 0.368, closer, although not what we want…

Here’s the trick…

Unscrew your tank, press your fire bar to makes sure it says check atty or something similar.

Screw your tank back on, and new will still say 0.398, old will now say 0.368.

Press old, go back into adjust ohms take her down again (now 0.338), unscrew your tank, press your fire bar to make sure your mod has registered that the tank is off, screw your tank back on and repeat until you have your desired ohms.

Even if your coil is slightly off as some of them can be I like to use the ohms it says on the box, on the side of the coil or on my ohm reader.

So even if your mod is slightly out from the advertised ohms, for example the true reading on mine was 0.348 not 0.300.

Nope, I want what is says on the box. Now even if you turn your Alien off at night, when you fire it back up, the same message will pop up, just choose old again and your ohms will stay at your preferred reading.

Hope this has been helpful.

And thanks Smok for letting us defeat the ±0.030 limits :wink:

All the best



Wouldn’t let me update mine - kept saying ‘no such USB device’ :tired_face:

Hi @Lolly

If you’ve not tried this yet, hold the fire bar down all the way through the update, that’s what I did, there are also two versions of the Alien A & B, this is for A, when fired up it should say something like, V1.2.2.

Also remove your batteries and if it fails again use a USB lead from a different mod, I had to do this with my G-Priv.

Also hold your fire bar when you plug in your USB lead. And have the upgrade software open then click connect.

Fingers crossed you get the new firmware on your Alien :alien:


1 Like

Thanks beaut - will give it another whirl tomorrow.

Hadn’t thought of that :+1:

1 Like

Awesome cool stuff @Lolly let us know what happens :wink:

1 Like

Used a different cable and eventually got it to work! Whoop! :grin:


Hi @Lolly

That’s great news, very pleased for you, those mod cables can be a pain in the bum, it’s happened to me before.

So glad you got it sorted :grinning:

Enjoy your new :alien: firmware.

And have a great weekend.

All the best


1 Like

Just did the update to 1.3.2 and i had trouble due to the USB cable not fitting right but that was an easy fix and it worked fast and easy it really is a nice little update.


I have recently experienced an issue with my Smok Alien 220W as it now reads Low Ohm on all of my RDAs or tanks I put on it. They all read at 0.00 Ohms and will not work/fire anymore. Has anyone else experienced this issue and do you think this update could help fix the issue? I apologize for the questions but I am not ready to throw it away just yet. Hell, I only used it for about 2 months.

1 Like

update could help. Also make sure that you don’t have ejuice on your 510 connector.


Also, there is a 6 month warranty on the Alien. So I wouldn’t recommend throwing it away even if it is broken.


Thank you for your reply

I know that prior to doing the update the ohms on my alien had started jumping all over the place but I didn’t get any low ohms warnings. The update has fixed this (touching wood) :+1:


Sweet @Kracker glad you like the update, it’s definitely the best one yet? Now the TPD is up I think Smok are getting back to the technical stuff :slight_smile:

Hey there @Mourning_Glory @Jooshwa and @Lolly gave some good advice, don’t give up on your Alien :alien: An update will not hurt and may fix it, if not warranty, and if so be quick, Smok say 6 months although in reality it’s 3, I’m sure you can revive it though.

I’ve got a Goon 1.5 on mine at the moment and I been dripping a bit much to say the least my 510 is covered in juice and it’s still firing, so could be faulty, so don’t hang about if this update don’t fix it, send it back and get a replacement.

Wish you all the best.