SMOK XCube II Titanium TCoR Setup Issues

Continuing the discussion from SMOK XCube II review:

Although I manually set my resistance @ .12 ohms, the mod won’t stay there. It keep reverting back to .08 ohm, which is .04 ohm lower than the resistance of this coil setup.


The problem I have with this thing is that when TC kicks in it often just reverts back into wattage mode and also I have had dry hits when it is in TC mode??? So far my solution has been to use my IPV4s for TI and TC because this thing just works and I now use SS coils for the SMOK and vape in wattage mode since it works fine that way. When they come up with a decent fix for this thing I will try TC again, until then…

[quote=“Pro_Vapes, post:1, topic:27865”]
Although I manually set my resistance @ .12 ohms, the mod won’t stay there.
[/quote]I don’t have this problem, just the above mentioned.

1 Like

Usually if it’s jumping out of TC there is a contact problem.

  1. Make sure you a spaced coil build.
  2. Make sure your post screws are tight.
  3. Make sure your build isn’t touching any part of the deck or housing.
  4. Make sure you have good contact on your 510 pin.
  5. Set you resistance at room temp.

Adjust your TCoR… you have to keep going up until there are no more dry hits. I have ended up on .00525.

Nothing on mine is accurate so I cheated until it worked.

1 Like

I understand you can only do that through the app which I don’t have cause I’m a dinosaur and have a dumb phone so it’s wattage mode for me I suppose.

[quote=“Pro_Vapes, post:3, topic:27865”]

  1. Make sure you a spaced coil build.2. Make sure your post screws are tight.3. Make sure your build isn’t touching any part of the deck or housing.4. Make sure you have good contact on your 510 pin.5. Set you resistance at room temp.
    [/quote]Those I have done and are fine.
1 Like

Those are all the bases I check and TC usually works. What wire are you using?

I’m using SS at the moment, activated through someone else’s smartphone :grinning:


I haven’t tried SS. I think some has… maybe they will chime in.

I tried SS in TC at 1.091 and it reverted back to VW as well - Haven’t tried with 1.092 yet…

1 Like

I’m using it w a .7 ohms stainless spaced w the 1.092 and it fine @ a tcor of. 00190…no problem
crown rba

1 Like

Well, I just use it in wattage mode now and don’t get any dry hits at all so I say F the TC, I’ll use my IPV4s for that! I can do without the headache.


I just pulled the trigger (or rather “trigger bar”) and bought this mod yesterday. It is in transit.

I just wanted to say thank you to all of you for blazing the trail and sharing your insights.

Temperature control with TI is where I’m headed in the next few weeks based on your contributions regarding its superior flavour.



Jimmer I think you’ll like it. Be sure to do the firmware upgrade.

I’ve been using mine in TC with varying degrees of success…though I’m going to say I’m very happy with this mod overall. Here’s what I’ll chime in with -

  • Performance is not entirely consistent. Sometimes it works like a
    champ for a whole day. Other times I have to play with the temp
    and/or coefficient to get a decent vape. I’m not sure what the
    problem is here but could certainly understand if it’s something I’m
    doing wrong.

  • The NEW COIL, Y OR N function does not work if you select NO.
    Meaning if you remove your tank or RDA you have to wait till it’s
    at room temp again to set up properly.

Issue I discovered with TI this week -

I’ve tried rebuilding Subtank Mini coils using titanium/vertical builds. No go. I don’t know 100% if its because the leads need to be the same length or if it’s the length of the leads themselves. I’m thinking length because I tried building on my Freakshow with dual Ti. The freakshow works best if you position the leads directly over the air intake. To do this your leads need to be a bit longer than most RDA’s so you can move them…center positive pin is just that…in the center. So the three post design means moving the coild substantially left or right to center over air holes. But whether it’s the overall length of leads, equal length of leads or what have you, on both these builds I got glowing leads under TC so scrapped them entirely.


Thanks for the advice. I am pretty patient when it comes to techy stuff. But I am MORE grateful that this (and other) threads exist outlining the challenges that lie ahead.

Cheers SthrnMixer and others contributing to this thread!

1 Like

Unless you specify the ohm yourself? (On the mod: Settings - Adj. Ohms)

That’s a flaw in my view. I love how it works on the eVic. You can remove a hot tank for refill, return it to the mod and select No for new coil…and it works like a boss.

1 Like

I actually think it’s cool that you can specify the ohms - My eVic almost always reads it 0.02 ohms too low when I “start a new coil”, so to speak.

remember it’s designed to sell with the tfv4 so… I actually use mine with the crown so…but I have a. 22ohm stainless coil and set the tcor??? just right I guess and have had ZERO AND I MEAN ZERO problems none at all vapin about 3tanks a day…

Uploading 1442522121976590973350.jpg…SUPER DUPER FKN FLAVVVVVVV

So are you guys paying the little $0.49 to upgarde to Ti and SS? It would not let me enter in the correct tempco until I bought the Ti upgrade through the app. Makes me wonder if the prices are so low and this thing so awesome because they are going to steal your information and make their money that way.

I’m just getting into the single coil Ti build, first time with building in a tank and first time using TI and TC at all. So far I am a bit underwhelmed. The three coil head in wattage mode really chucked vapor and flavor, but it was a little too hot for my liking. . .about like an artisenal way sub-ohm coil build on a high end mech mod. It’s nice. . .but $5 coils

Hmm, writing this I just switched over to watts and I’m running out of juice with 60W. . .I guess my hemp wick is not working well with the really tall coil I built. . .it WAS ugly.

my resistance reads correctly, but i dont like the vape at all unless i change the tempco to 0.005ish.

What version of the firmware are you running? I had to adjust my TCOR with version 1.80 (the version my unit shipped with) but it works at default setting (for me at least) after upgrading the firmware to 1.92.

I hope this helps.


1 Like