SMOK XCUBE2 Activation Test

If I could downgrade to v1.080 I think it would I could get it to work…

Unless you write a code that will push it from the upgrade software as an ‘update’ then I don’t think downgrading is even a possibility here.

The old installer will wipe the chip and install the v1.080 hex file.

link to the old installer and the 1.08 hex?

That’s what I’m looking for. Smoktech hasn’t replied to a support request. That’s why I will never but another Smok mod. They obviously have an as is policy… They know they are producing bad mods.

So in the US Madvapes LLC is their warranty provider. I called them and asked them about this issue and they said they have gotten numerous RMA’s because of the mod not working properly on all different aspects.

I threw in a spare triple coil for the TFV4 and put it in watt mode and guess what, it fired… In TC it fired on my Ni setting. Still cant change to Ti no matter what and still says short atomizer for all my Ti builds.

I was starting to think that it was the app that was not working properly. Now I see that it is this mod all together. I’m at the point of pulling my hair out this is such a headache. Even for us experienced TC users, this is such a gimmick.

1 Like


Firmware version V1.08 (zip) -
Update Tool -


It didn’t work… No data file included

it has the .hex you can use with the old updater.

just did it to mine actually.

When I tried the failed. I used the old installer. I got a pop up saying no data file. Did yours downgrade successfully?

Old installer:
First choose Erase All and start, once that completes proceed to load new firmware.
Find .hex file, extract it from zip folder or just move to where ever you want.
Open the Upgrade Tool (old one).
Click on the APROM and find the file (note: here you must change the file type from .bin to .hex so you will be able to choose the .hex or else you see nothing)
On the bottom, you want APROM and Config checked. Then start.

Btw: I downgraded to 1.091 and that didnt help, also downgraded app from 2.5.1 to 2.5.0 with no luck. Trying my last working option:
Firmware - v1.08
App - v2.4.5.2

I have the old installer but the only old hex files I have are 1.07 and 1.09. If anyone wants them pm me

I have 1.08 and 1.091.

Unfortunately I think for me and @Pro_Vapes it’s our actual mod. So many of you guys have working ones.

My options now are to return to gearbest or send to Madvapes for a replacement…


It works on 1.08 @Pro_Vapes!!!

I FINALLY have TI setting in my modes.

What a fucking fail, excuse my language. 4 hours later

My mod still reads short atomizer when setup. Though it reads 0.07Ω and it was 0.07Ω on my evic… So still can’t vape :frowning:

1 Like

I even tried v1.093 same here. You have the same bad mod as me. I hope people are taking notes. SMOK is really on some BS… selling garbage.

1 Like

I am at v1.08, working Ti, but gives the short atomizer on every atomizer I have since I use Ti strictly. App still won’t push any of the settings I change on it to the mod itself. Funny thing here is, mine is the SS and yours is the black one which they just put into production. This issue was known about then and they took no steps to finding a fix for this issue.

I will be sending mine to Madvapes LLC. I will have to spend another shipping cost just to maybe get a working X Cube II. Oh, and wait another 2 weeks after the few I already have…

Smok lost my business after this headache even if I get a 110% perfectly working one. It won’t give me back these last 4 hours I’ve wasted for absolutely nothing. :thumbsdown:

1 Like

just a question… did you guys verify the are authentic???

So I just received my cloud kit prize and the cube that came with it is lesser quality than the one I bought. Just like you asked Ryan one of the buttons sticks up higher than the other, it rattles in the buttons, the screen quality is darker and it also has and engraving that says not for sale for sample only. I think they sent out the pre-production models for the winners but I can’t really complain since it’s free I guess… The tank is a beast though

1 Like

yes, smok’s site says that it is authentic. Made on 6/19/2015

1 Like

Also guys depending on how long you have had the beta installer, you can find the hex files in the install folder as well