SMOK XCUBE2 Activation Test

I didn’t think to check… but I’m on it right now.

The app shouldn’t recognize a fake. You’d think.?

This is too technical to fake and dupe the app…

1 Like

Yes it does

not the app that’s dupped but all the app sees is a blue tooth device and maybe just maybe that’s the conflict in software??? just a thought and the pc just sees a USB connection??? idk I’m racking my brain trying to help you JUST FKN VAPE bro!!! it’s killing me I can imagine how you feel :astonished::confused::cold_sweat::smiling_imp::smiling_imp:


It’s quite whack to be honest.

I was at the point of throwing mine out the window, so i calmly packed that pos back up in the box so I can return it or RMA it.

1 Like

So I did some digging on my desktop and I have these hex files for anyone else that needs them - vr1.07,1.08, 1.09, 1.091,1.093 along with the original (working) updater

1 Like

I’ve seen what you guys have gone through with the x cube, which also includes mine, I’ve had nothing but problems since i got it. @pro_vapes, you must be pulling your hair out by now, i basically put down to to it being a pile of utter crap. It has so many options to do this and that, some of which you have to pay extra for, as if you haven’t paid enough, and which none of them work. It’s basically a vv/vw mod with a dodgy tc function. I for one will never buy another mod from smok. The TFV4 and mini are good tanks but that’s about all from smok.
I use my e vic mini with the same tanks that have just been on x cube and they all work on the e vic yet on the x cube, not one will function properly. Mines going on ebay this week. Cant wait for my IPV4s.

Can you at least give the new firmware a chance before doing that? I don’t know if it will help but it’s worth a try. And I have a suspicion that 1.093 may well salvage some of the wonky units out there. I had learning problems with mine at first but right now it’s my absolute favorite by far. I did the firmware update today and all works perfectly. Release was yesterday.

If you do the update and it still doesn’t work right, and you’re in the US, pm me your price and if I think it’s fair I’ll buy it from you just so I can tinker with it.

It breaks my heart to see everyone wanting to throw away or sell their cubes :frowning: Besides the updating tool both of mine have worked like a charm and I wish I could offer up some help to those that are having issues. I love my cube but I HATE smok as a company and as programmers. The only other issues I have ever had have stemmed from the ridiculous “app” they have. I refuse to use it and have done everything on the mod itself only! I have seen a lot of horror stories after people change this or that through the app and I’m done with that POS
as @SthrnMixer says at least give it a chance first if you can? I can only hope that it is a matter of time before they release a new firmware update that will help you guys

1 Like

I feel the love for sure. And I’m the same way. This was an exciting purchase for me and I’m glad I wasn’t a “victim” of bad programming. I can’t complain in the least.

The release notes for v 1.093 says

  1. Adjusted max wattage to 180W,bring you ultimate vaping experience.

2. Improved function on alerting the initial resistance is too high or too low.

3. Revised the issue that the temperature unit is out of sync between device and the APP

I’m hopeful that 2 and 3 will fix some problems people are having. Number 2 is substantial.

1 Like

I was not aware of this?? Although I currently have no setup that will handle anything above 140, that’s pretty damn cool they can raise the wattage like that…never saw that coming!
I stopped updating mine after 1.09 because everything works so why update but now that they raised the wattage I may have to update…just to have it hehe
@SthrnMixer are you able to successfully use the beta updater tool? I cannot on either of my cubes for some reason? I have the 1.093 hex file but yet the firmware it shows after updating is only 1.091??
Thankfully I saved my old tool but it is pretty shitty of them to take down the tool that works only to replace it with a faulty beta copy. I want to use the new one because it’s so much easier but I cant get past .091

I will say my Smok contest cloud kit prize was a bit shitty…I think they sent me a pre-release sample vr of the cube…the one I bought is SOLID and this one rattles a bit, the screen is A LOT darker and the buttons stick out at different lengths. Thank god the tfv4 isn’t the same cause that’s all I really wanted!!

1 Like

I’m sad to see that as well - It is one of my favorites… I do understand it, when they experience so many problems with it… Mine is a “Sample not for sale” - but the quality is great and it just works for me…


That’s the one I got in my prize kit too! Mine is of lesser quality though but like you said it just works…

1 Like

Yes. The updater tool is v 0.9b. It’s basically the same as the other updaters. Install and run. The difference is with this tool you take the batteries out, click and hold the fire button and then plug in the micro USB - continuing to hold the fire button. You will hold until update is complete. Once connected click on check update. It will find the new update and you click again to update - holding the fire button the whole time. Once complete you just click ok and x off the updater. Unplug, put the batteries back in and voila, all done.

1 Like

@SthrnMixer @DarthVapor ive just sent an e mail to smok to complain about it all, probably just a rant, but I’ll try the new upgrade and see if that sorts anything out. Just sooooo frustrating. I really don’t want to get rid of my cube but theres only so much one can put up with. I’m getting myself stressed over a mod that should work. :disappointed_relieved:
I’ll try the update tomorrow, nearly midnight in the uk, been a long day. Look at it with fresh eyes then. Thanks guys.

Yeah that’s how it is on the original too, minus holding the button through the entire install…
I have the latest and it still goes to 1.091?? I just tried my new cube and it was at 1.08 before the update and finished at 1.091 even though I only had the 1.093 hex file…aggravating!!

Good luck trying to understand their response!! lol their english is horrible and I have gone back n forth with them a month ago and it was like talking to a 4 year old zwahili boy…

@DarthVapor Good luck trying to understand their response!! lol their english is horrible and I have gone back n forth with them a month ago and it was like talking to a 4 year old zwahili boy…
love that. :joy::joy::joy::joy::joy::joy:

I noticed when doing the update that as soon as I hit “check for update” that the folder I had the the update tool in had the hex file for 1.093 show up. Question - when you download the new updater is that getting its own folder? If not, move it to a new folder and try again. Or I could send you the hex file if you like.

1 Like

That’s what I currently do to get the hex files for the old updater :smile:But yes it is a new install with no trace of the old copy and I haven’t actually updated to 1.091 before so that hex file has never been on my pc.
There is a handful of people I know that have the exact same problem! I know @ffrank does as well

1 Like

just finished and almost sorry to say it’s running flawless w a. 20 ohm ti coil on the tfv4 rt1!!! just awesome I wish the others weren’t having issues!!!

1 Like

Here’s a link to their old installer page with instructions. Personally I highly recommend everyone pick this up so they have it. Much better update tool and you can save the settings on your mod so it doesnt wipe it every time