Techie Help? Brand New Vandy Vape Revolver 25mm RTA Killing Coils 2x Daily!

Ok, so my guy and I are long time vapers, but we’re not quite ‘tinkery’ enough to figure out what’s happening, here. I just bought a Vandy Vape 25mm Revolver RTA, got it last week, and the darn thing has murdered on average of 2 coils a day! Not sure what the issue is… could it be a grounding problem? We’re just hoping someone can talk us through a simple fix.

I was vaping MTL Fused Clapton Coils at .6 and .7 ohms, and typically vape low wattage, between 17 and 20 watts. I don’t think there’s anything awry with the coils themselves, because they work just great in 3 other RTAs and an RDA. But for some reason, I just can’t keep them functioning in the Revolver. Also, even when they were working, there was serious flavor muting going on with the Revolver. Flavors were tasting about 1/2 strength when compared to an OBS Crius RTA. I figure that can’t be the norm with the Revolver, or it would have come up in the reviews.

Does anyone have any ideas on how to Macgyver this RDA? I got a great deal on it, so wouldn’t be end of the world if I couldn’t get it working, but still, no fun at all. Plus, I’m on a mission to find a simple build single coil RTA that comes with a bubble tank, and I was SURE the Revolver was it. If it can’t be fixed, I’m back to drawing board.

Seriously appreciate any help ya’ll can offer! Yell out if I’ve left out any necessary details.

Thank you, thank you!!



Perhaps defining “murder” would help. Are u popping the coil (snapping the wire) so the resistance changes? Perhaps its not wicking correctly so u mistakenly think there is a problem w/ the coil which would explain the flavor loss.


Great question, and that’s part of the issue we’re not understanding, because every time a coil dies, its a little bit different than the last. I think the coils must actually be blowing, because I’m getting error messages like ‘no atty’ and ‘cannot read resistance’ on the Revolver. But the errors are preceded by worse and worse vape, like almost impossible to draw, flavor gets more and more muted, really irregular readings on resistance of coil, and then pow! Error message and it won’t vape at all anymore. BTW, using a Tesla Punk Mini mod, which is where i’m seeing the errors. Used at least 5 different RTAs and RDAs with this mod, and I’ve literally never seen any of these error messages until the Revolver. Really strange. But definitely not a wicking issue.


hmm, i doubt u did it repeatedly but make sure u clip the extra leads so they dont contact the barrel (chamber) You should always check the resistance before and after screwing on the barrel(chamber) to make sure its not touching. Could be your 510 is loose, not sure if thats adjustable but it should be tight. besides that it could be the 510 isnt long enuff for that particular mod, try on another if u can, or the 510 pin on the mod is actually stuck down from being used with an atty w/ a really long pin. GL to u!


Well there’s a possible red flag right there! Did you buy it brand new unopened?
Uh…nevermind. I can’t read thread titles!


This could be a result of overstuffing the cotton. Either in the coil itself, or choking off the fill ports that the cotton threads down into.

The one thing I’ve just experienced with the same ceramic clamp system that is used here is that it apparently wants to loosen over time. I assume due to expansion and contraction of the ceramic from heat being applied…
I have the VV Hermetic, that I’ve been using for almost a week now, and it and the Blitz Ghoul use the same ceramic clamp. Perhaps someone with a Ghoul can confirm the experience.

At any rate, my impedance was jumping around pretty badly after many refills. The coil was never damaged, but the vape was getting worse. When I pulled the top cap for a visual inspection, nothing obvious was wrong, so as usual, I grabbed a screwdriver to make sure connection points were snug. And low and behold, the ceramic clamp was shockingly looser than expected.

Thankfully mine is the rda version. As even if this is a “fatal flaw” in the design, it’s not a deal breaker to pull the cap, and tighten things up every once in a while. Whereas in your case, if you have to drain the tank to check (I’m not saying you do, I’m saying I don’t know) that would be a deal breaker for me. Hopefully you don’t have to though!


Hehe it might look like a easy to build rta, but like most VV products, nothing is just simple.

They either hard to build or nearly impossible to wick etc. It’s like you need a Bachelor’s Degree for their damn hardware, even then it’s sometimes just not working.

But if you get it too work, most their atomizers, can be extremely satisfying and hard to beat.

I own a revolver, as well as other single coil atomizers but I do need to go to work and don’t have much time to help, since it will take some pics and some explanations.

I am more than happy tonight after work, to add a run down, if nobody beats me too it, and you have the patience too wait. I’m really sorry for not doing right away, but wanted to respond at least.


Thanks! I’m pretty sure its not the cotton, because I futzed with the stuffin’ every single time it happened, trying to get the sweet spot for that RTA. I tend to understuff, as opposed to overstuff, because my least fave thing ever is the ‘frying cotton’ vape. But I definitely think you might be onto something with the clamp system loosening. I had AWESOME experience with the OBS Crius with the clamp system, so I kinda figured the Revolver would be similar due to similar design… but we all know how assumptions work. I’ll try to clamp that thang down hardcore every few hours, see how it goes. Even if its not a viable long term fix, if I cease having the problem then we’ll have identified the issue. And thankfully, I can just invert the tank, pull out the build deck on bottom to do so. Full tank no worry.


eStorm, no worry about the wait, at all! I’m just so grateful someone with Vandy Vape tinkering experience happened by. I’ve used a lot of hardware over the years, but this is my first Vandy Vape anything, so if its not an obvious issue, and not covered in reviews, I’m sorta shooting blind with this tank. I’ve got backups, happily puffin’ away on a Doge v2 RDA now, so no hurry at all. Thanks for any suggestions you come up with!

And can I just say, you guys are awesome! Thank you all for all your great suggestions.


As far as I can tell, definitely not a clone. It came in all the Vandy Vape packaging with the serialized scanner id on the side. I just stumbled along a killer deal at Breazy for $10 on the Revolver, and a Doge V2 RDA for $5.They’re both authentic, I think just good deal because the versions are a few years old, and they were down to kinda fluffy girlie colors. Hey, I’m cool with that. I’m a girlie vaper. :wink:


I would try out on different mod eliminate that out of the equation just my two cents worth


I’m successfully using 430SS Clapton wire (26g/30g) 5 wraps 0.24ohm. vaping it at 42w in my Revolver.
What material and gauge wire are your coils?


@CosmicTruth , we’re lazy builders, and use commercial coils. lol I was using Geek Vape MTL Fused Clapton Coils, Made of N90, Nichrome, I think its called? Supposed to diffuse heat evenly.
Exact description is below, and I tried both of these varieties in the Revolver:

MTL Fused Clapton Coil (4pc) - 28ga*2(=)+40ga - N80 3mm (6 wraps) @ 0.6ohm

MTL Fused Clapton Coil (4pc) - 28ga*2(=)+38ga - KA1 3mm (6 wraps) @ 0.8ohm

Here’s a link to the same product if you need any specs I haven’t thought of:

Didn’t occur to me before now, because I usually vape higher Ohm, but I’ll try it out with the pre-built Clapton it came with, as that’s a lot closer to what you’re using successfully than anything else I have in the house. According to the specs its KanthalA1 24g/32g at .3 ohm, 6 wrap.

@RexRabbit , That’s a good idea, actually. Thanks for suggestion! We’ve only got a few mods in the house, but I’ll try it out on my guys Tesla Punk full size, as well as an Aspire mod.


The only thing I can suggest, if it continues giving problems on a different MOD is to open it up and be sure it is not coming loose (as suggested :point_up_2:).


I’ll try the Kanthal it came with, and crank clamp down regularly on another mod… then try to isolate which is the issue if it goes a few days without popping coil. I’ll let ya’ll know how it goes. Thank you guys, bigtime! This is such a weird issue for me. I usually go a good 3-6 mos on a coil, cleaning and re-wicking a few x a week, but usually give in and replace the coil before it pops, just because it seems like time. Losing them frequently like this, its got to be a short or loose connection, somehow. Crossing fingers. If this doesn’t work, I’m going to give in and get an OFRF Gear 24mm, I think. :slight_smile:


Because the fused clapton coils are a flat wide coil element that can be problematic if one leg is twisted and the 2nd one is flat. bend both legs so they come off the coil flat:
and if it looses conductivity just remove the tank and hold it upside down and remove the bottom. then tighten the screw holding the coil as tight as you can, it should begin working again.


So let’s begin here, I took some pics (not the best because im tired lol) this might make the explanation easier too.


If you take a look at the clamp, this thing is not straight. On top it is, but going down towards the bottom it narrows down and leaves a very odd space between the posts and the clamp itself. Also since this clamp isn’t spring loaded, holding it in place while screwing down the coil, is important. If the clamp turns just slightly left or right, this will show the error later on, at least in my experience. Lets move on

Coil Height:

When installing the coil as seen here on the picture, this will cause a huge issue as well with the clamp. This coil due to the thickness of the wire will lift that clamp. Moving it down like this, is something you want to do so that you get good flavor, but again not possible if the legs are on this side. You will have to make sure, that both legs are somewhat flat in one direction, if that makes any sense. (Only reason i installed it like this is to show, that this won’t work lol)

Another important factor at least in my opinion, thick wire won’t work, the clamp is not strong enough to hold them down, no matter how hard you screw/tighten that down. I personally found, that more roundish wire will work much better than fully flat, in this rta. As well as the size.

Funny enough, I installed the coils that came with the atomizer, and got the same error message every time, either during dry burn or a couple of hits, due the the wire/legs being too thick and wide for that rta. Go figure since nobody at Vandy Vape apparently vapes, and just threw some coils in that pack without testing. Here are the pictures.

If you look at the clamp, this is what happens with their coil installed and/or coils that are made out of thicker wire, this clamp not only loosens but shifts causing that stupid error.

When cutting the ends of the coils, make sure you’re reaching inside the little grooves on the deck and cutting the legs as short as possible, not just “flush” with the deck, like you would in other rta’s. Otherwise you run the chance of shortening through the top cap.

If all this wasn’t your issue, well lets look at the last problem this rta can cause if not careful. Again I installed this on purpose like this, too show how it should not look like!

This picture will show how the wrap was pushed by the clamp right into the post. This happens very often, if a the wire is too thick, there’s too many wraps, or you didn’t squeeze your coil together while tightening that screw down.

Here’s a picture of the other side, that’s how it should look like, the leg should be straight underneath the clamp, positioned somewhat in the center.

Now i will tell you this, this rta is not meant for small coils. I vape at lower wattage too, not as low as you do, but in comparison to others around here it’s low lol. Due to the massive airflow and it doesn’t matter which one you pick, the smaller wires will have no chance on delivering any flavor since the air just flies through them, especially if you compare it with products that are made by OBS.

I took another picture to show, how your coil should fill out the deck, if you plan on getting flavor lol.

You can go bigger or smaller of course, but what I am trying to say is, if your coil is extremely spaced or only covers these airflow slits half way, you will experience very muted/washed out flavor, at least in my opinion. This is a 3.5 ID twisted SS coil, I run this in the revolver at 55-65W, not the way I normally vape but anything “smaller/thinner” is just not satisfying.

Here’s one more picture of a baby alien, I have in my hermetic RDA (works perfect in there especially with that “better” clamp), tried using this one in my revolver prior, and it didn’t do well. All I got was slightly flavored VG with a very cold vape, even closing the airflow and turning up the wattage, didn’t do anything for the flavor, because that rta is not meant for small coils like that or even smaller :slight_smile:

Hope you get it working, because if you do, it’s a really good RTA. If you have questions feel free too ask, just got off work and I might have forgotten a couple of things here, or made phrases that might make no sense lol.


Holy tar, that was SERIOUSLY helpful @eStorm! Thank you!!! And I’m not sure why i was having the issues before with my coils, but seems like it doesn’t matter, because those geekvape coils are TEESY WEENSY when compared to the coil included in the package with the Revolver, and near microscopic compared to the coils you’re showing on that sucker. So even if they had continued to work, no way would i have gotten decent flavor, based on your lil handy dandy tutorial. Oddly enough, my clamp is different than yours…not metal, its black… I’m thinkin’ delrin? But still has that strange gap thing happening. And thank you so much, because I’m definitely going to have to invest in some new coils to get any kind of performance out of this thing. I’m glad you came along, or I’d have fried thru all the other varieties of tiny coils in my house to figure that out. I’ve actually been thinking of getting some multipacks with some larger more elaborate coils so I can decide what I like enough to invest in rolls of wire and tools to make my own.

As for update, I’ve been functional with the coil included with the Revolver tank (which is odd, since they were so bad for you) for 2 days now. I’m regularly re-tightening the clamp, which I think is helping, also. But doesn’t seem to matter because now I’m having crazy wicking issues with it… everything going fine, and then liquid just pours out the airholes. So weird. I’ve re-wicked no less than 4x over last 2 days, a little differently each time, and followed 2 tutorials on how to wick this tank exactly, and still pouring out. Beee-zare.

I think its official… my Vandy Vape karma just sucks. And @eStorm, you’re SO right… you need a dang degree in vape-ology engineering to make one of their products work! lol So i’ll keep playing with it and figure out wicking, get some new coils… and this sucker will be a very pretty back up tank. lol I just don’t have the energy to wrastle with the damn thing on a daily basis.

Thinking I’ll grab the Gear RTA…I’ve seen some great reviews, and love the itty bitty size, so hoping that’ll work better for me.


No problem at all, as I said, some hardware can be trickier than other and some are just not worth the hassle :wink: Let me know how you like the gear rta, if you decide on getting it.


That’s odd…
In the pictures she posted, hers looks like black delrin to me.
Stranger still…
As I mentioned before, mine is ceramic (white).

@eStorm is yours actually delrin? Or is it actually ceramic, that’s just a dark color?

You should be able to feel/hear the difference.
Delrin (as I’m sure you know) is plastic.
Ceramic should have a kind of glass ‘tink’ to it if you tapped on it with a screwdriver etc.