Vapor Shark Sucks!

Hello vapers! :slight_smile:

Sorry for my long post but I just had to let that all out of me!!! I know that you’ll understand me, 'cause this is one of the best communities ever! :))

My first DNA200 Mod was Lavabox by Volcano and I wanted to buy it to my wife too but when she tried it, she complained about the weight and the size, she wanted something else … couldn’t convince her.

So I’ve started my research on the web. I knew that it should be a mod with lipo, as it would have a lighter weight. So eventually, after watching reviews and cheking out the sizes, I came across the VaporShark DNA200. I’ve read that this company had issues with their products before but my wife chose it anyways. My Women gets whatever she wants from me usually :wink: so I’ve bought it for her :slight_smile:

After a month, buttons on the mod began to have issues… After a month and a half, when the button was pressed, sometimes it fired and sometimes not. My wife is a super gentle user, so she couldn’t break her mod or buttons, I’m sure!

I’ve asked vaporshark to fix it and first they didn’t want to take it back, because I’m from Russian Federation. They’ve told me that it’s because of sanctions. What a bunch of bullshit! I’m an ebay seller - I send most of my products to US during all this time and never had an issue. Also I buy a lot from US, different kind of stuff and I’ve never had an issue. Anyways, after some time, they’ve accepted to take it back and told me that USPS will contact me in a day to pick it. After a week no sign. Wrote VaporShark back. They’ve told me - ooohhh, they’ll contact you tommorow. 2.5 weeks has passed!!! … and finally the mod is on it’s way to US.

After almost 3 weeks in US there was no sign of my mod. I wrote VaporShark and they told me - ooohhh, we forgot to tell you, we’ve sent your mod to your other adress as there are sanctions on Russian Federation.
When I’ve ordered my mod, I was not in Russian Federation. Did a project abroad and used some other persons adress. But I’ve payed from MY card with MY name on it. VaporShark WITHOUT asking me have sent my mod to the other country.
It was a total mess for me, as I’m not in touch with that person in the other country. It was a short period of time that I’ve spent there and I had NO contacts of that person at all.

It was so disappointing, I’ve waited so long already and they didn’t even ask me what they should do!!! And that bullshit about sanctions again! After writing them some angry emails, they’ve told me that they will send me a new mod if I’ll find someone in US who will send me my mod.

No problem, googled it and found companies which send stuff from US to Russian Federation. It took me 5 minutes! Told about that to VaporShark. Their answer was - YOU will pay for the shipment, because there are sanctions on Russian Federation! Now, after they’ve sold me a broken mod I also needed to pay for the shipment. Ok, I’ve payed almost 40$ and waited for another month.

I’ve recied my mod today. opened it, connected the battery, plugged in the charger and NOTHING is happening. Charge level stays on zero. Tried via computer, same story. tried via Spark - NOTHING. tried with different cable - SAME. Reboot and restore defaults and every other options in Evolv didn’t solve it. The lock button works, - and + works, but no charge :(((((((((((

I’m SO SO SOOOOOOOOOOOO disappointed!!!

Don’t they check their mods before they send them to customers?!?!?!?!?

Lost 2 month and it’s the Second time I’ve got a useless piece of metal. First time for 199$ + 30$ shipment and this time payed additional 40$. Great! I’ve bought a mod for 270$ which I can throw away. Usually, I don’t get angry at life situations but all this story is just so stupid and annoying, that now I do get angry. It’s so disappoiting that my wife has to vape using shit mods all this time she waited for VaporShark to solve “sanctions” and fixing problems… what a mess.

It’s a pitty I din’t buy another Lavabox and waisted my money on vaporshark !!! It’s amazing how many people had got issues with VaporShark and they’re still working and selling their products. I’ve read about many problems that they’ve had with their devices…

I have been using my Lavabox mod for half a year and I have to tell you its PERFECT! Great quality, great performing, comfortable size, good grip. It performs like a monster and now, after we have an option for a new battery - you won’t ever need any other device.

That is my opinion of course. But I’m telling you, this is THE mod! I’ve bought a Vaporshark dna 200 for my wife, because of the lighter weight - she told me that my Volcano was too heavy, but as a result, we’ve got a very disappointing experience.

Vaporshark’s design is not comfortable in the hand. It looks like a brick. I don’t know why, but it performs worse than volcano, even though it’s the same chip. Waste of time. Lighter weight for couple of grams, that’s the only good thing about it. The price is higher, the quality is shitty. If you’ll look inside the mod, you’ll see how much better Volcano is.

Conclusion - VaporShark is an overpriced product that just made better commercial steps and advertising. Their products are worse and cost more!

Sorry again for this long post. I go and meditate now to calm down :slight_smile:

1 Like

Damn…so sorry to hear this. Thank you for the heads up.

1 Like

My VaporShark has been returned twice. That zip charge idea was dumb on someone’s part. Because it doesn’t matter what kind of charger you have. A 900mAh battery should never be charged at more than 1 amp. PERIOD. Actually, you shouldn’t charge at more than .9 amp. But .1 over isn’t that bad. But it’s not good either.

1 Like

My question is - HOW VaporShark are still selling if they have a pretty shitty overpriced product and so many people have suffered from their mods?

1 Like

Honestly yours and @LordVapor is the only ones that I know of that had issues with the Vapor Shark.I purchased mine due to the no questions asked repair policy that I haven’t needed.I guess their international sales warranty isn’t the same!
Sorry for your troubles @WhiteRaven , that sucks!


1 Like

that’s too much already, no?

what about the time, when they’ve just released their product and the entire delivery was defective? they had to take all of them back …

anyways, I’m done with that company :))

my wife will get a great new Lavabox dna 75 :slight_smile:

I have a Tesla mod that is essentially refusing to take a charge… serious anger with this because it cost a mint.

Sorry if you thought that I was taking up for VaporShark. I was only posting my experience and agreeing with you that VS handled your situation badly .:hushed:

I do thank you and everyone else that posts their experiences as it helps me and others decide on what to buy next.:+1:

I am quite sure going by the seven bad ones you found that the Vapor Shark will be the first one that will fail me out of the following that I own with Evolv boards.:scream:
Wismec Reuleax DNA200 , Lost Vape Mini Efusion DNA200 ,Protovapor Silo DNA200 ,Vapor Dna Project Sub Ohm S200 (DNA200), Axis Vapes M17 (DNA200) , Vapor Shark DNA200 , HCigar VT133 , and lastly a SMY SDNA75.

Every problem with the VaporShark that I have been aware of are bad batteries, and/or the charging circuit. Pushing 2 amps to a 900mAh lipo is bad for the battery and the charger. In this case… the built-in zip charger that manages to send 2 amps to the battery. The bad batteries (like mine) are due to this I am guessing. LiPo’s are finicky. If you don’t charge them properly they go bad.

Like my Tugboat for example. I use it every day. It rarely leaves my hand some days. I sent it back when I first got it, but that is because the shop I bought it from set the preheat to 200w. Which I later found out blows fuses. Since then I stay at 150w. It has never let me down since and I am very happy with it. My next DNA device will be another Tugboat. And so will the one after that.

just got a new extended lipo 1300 mah for my Lavabox, it grew bigger but I still think it’s one of the BEST mods! My pretty gentle beast! :))))

How this story ended.

Before posting this I wrote to VaporShark cust. service and didn’t get any answer around 3 - 4 days.

Don’t know if it’s a coincidence or not but I’ve got answer from them after posting all this story of mine.

I was moved from Mike Crespo to some other supporter Felipe Castano and he tried to help me to get my VaporShark alive using escribe. It didn’t work. But we’ve found out that the problem is in the LiPo…

Felipe Castano claimed that the problem with the battery happened because it took 1 month for a package to arrive to me. I’m pretty skeptical about this theory but… anyways, they’ve offered me a solution - as long as there are “sanctions” they’ve rejected to send me a new battery and they’ve just refunded me.

Wanted my mod and not the money but well…

2 weeks ago, before VaporS. got to me, I’ve got new extended battery for my LavaBox and I’ve had an old Lipo from it spare. I’ve checked it out and saw that it’s basically the same product but the cables didn’t fit. They’ve had different connectors.

So I’ve made a research and have found one guy who is good at fixing electronics and he accepted to try and to rebuild the battery connectors. He didn’t really have experience with mods but he took a try and it worked. He took connectors from the dead battery and soldered it to my old LavaBox battery… at first it didn’t work, he rebuilt it couple of times but at the end VaporShark came to life.