What's wrong with this picture?

Riding along in my truck, been enjoying my new stainless steel dual coil build on my x cube, all of a sudden I take a hit that feels like I’m sucking lava out of a volcano.

1 Like

What the …?! 553W? But… How?!

1 Like

Fuck if I know. I had been having some issues this morning with it jumping from TC-SS to watts. I played with the TCoR setting and it seemed to help. The suddenly this happened. I took the build apart and all seemed ok but it’s possible I suppose that one of the deck screws wasn’t tight enough. Still, that’s what popped up after that hell-hot hit. Ow well, I got may dual 22 titanium back in now and happy vaping again.


THAT is why I haven’t popped for anything having to do with TC. I’ll wait till some 4th Gen tech is out. The idea of hot metal in my mouth just doesn’t go with Unicorn Milk clone at all. Besides, I’m loving my iStick 100w enough with the Twisted Messes RDA sitting on it.

1 Like

That’s no fun. Where’s your sense of adventure? :smile:

1 Like

I bet you use Arch Linux or Slackware or something like that :confused: heheh


My first TC mod crapped out on me in under 4 days! :tired_face:

It took me a while before I took the plunge again! One day the right TC mod will catch your attention. Until then your “cents” of adventure can go into the bank. :wink:

Well the mod started jumping to wattage mode on the new Ti build too. So I redid the update to 1.093. That seems to have fixed it but time will tell. I suppose it’s possible the firmware could become corrupted but seems unlikely. But if that did fix it then it’s a good feature to have being able to update/flash firmware.

True…I haven’t updated my eVic Mini yet, but I hope all goes well.

Mine has done that a few times on SS - it looks like it needs to be “broken in” - then it will stay in TC…

The update for the eVic Mini is fast, trouble free and super easy. I wouldn’t even hesitate when you’re ready.

@daath Thanks Lars. I’ll try it again tomorrow. It is certainly a rigid wire and when it is working in TC mode the taste is clean. I still prefer titanium at this point. It’s the best but at least now my curiosity is just about satisfied. Well at least until unobtainium wire comes out.


holy shit!?!?!
dunno if I’d feel safe using that again. hope you didn’t burn your mouth to badly. That would be like eating a slice of extra cheese pizza straight out of the oven.

Just out of curiosity, did that hit significantly lower your battery power? Although I believe you, I have a hard time thinking the safety functions didn’t kick in.
Honestly, you would think the would have shut down long before it got to a fraction of that much wattage.

Maybe you accidentally hit the hidden apocalypse function.

I believe it to be just an anomaly. The device, nor any other I know of for that matter, is capable of that kind of wattage. Something had to have caused an issue in the board to make it show such a reading. My mouth was not burned it was just a very hot vape for less than a second. I wouldn’t be surprised if it was hitting at full power though which is 180 watts.

That is the exact thing that happened to my friend after using the POS app instead of the mod! He changed his setting so it would jump up in watts and back down when he took a hit but it jumped up suddenly to some insane amount of watts!
I’m not saying that’s what you did but that’s another reason I stay away from the app! Screws everything up!

If you update you have to use the app to get Ti and SS settings back. But that’s all I use the app for these days. The app won’t let you select dual or single coils so what use is it except for playing with the LED?

1 Like

Took care of that, went to Laos for 10 days. Been back about 3 weeks now. Nothing like going to a communist country to fulfill the adrenalin junky side of me. Ever go to a market where the security guards are packing AK-47’s? You haven’t lived. Vaping in public gets you looks like you are from another planet. That and being white, 6’4" and billowing clouds like the Naga…

1 Like

Nah, I’m a Kubuntu kinda guy. Actually on a windbloze box atm.


Has anybody had any luck tracking their “lost xcube2” or taken a (successful) look at your puffs in graph chart form???

I was only able to really change the color of my led, but really felt I had better control on the cube’s buttons.

This thing is packed with features for very little, so I’m not surprised, shocked or anywhere near upset if any of the unimportant features don’t really work so great, yet. shrug

…but volcano mouth does sound serious!

Mine does that regularly. I can’t even get tc to work at all. the only coils I have at the moment are the ni 200 triple, quad and rbd that came with the tfv4 tank kit. when I set it to tc, it switches to watts while the trigger is pressed and shuts off at 77 degrees…but it feels much warmer where the tank connects to the x cube 2 mod. it’s then displaying 553w in watt mode. very annoying, think I might have a bad mod because it’s never worked since I got it a few days ago. flashed to the 1.093 fw right away when I received it, so don’t know if tc was working on previous fw with this mod. wish I could flash back to older one. anyway, i’ll keep playing with it a searching here and there for solutions