Wismec rx200 temp control problems

Btw what a nice experience asking a question on this forum…what a delight…nothing but helpfull people…me gusta!


Yes, this has been a consistent problem with the TC boards Joyetech uses. Installing the atty when it and the mod are both at room temperature is important, but not useful if the mod doesn’t recognize it and take the initial resistance - key to providing good TC function.

One workaround I’ve found that seems to help is, with your topper screwed on -

Lock Ohms (click fire button 3 times, then the minus to scroll to ohms, then the plus to lock ohms)
Fire a couple times
Unscrew from the mod and fire (no atty)
Unlock ohms and fire (no atty)
Screw down atty and fire.

This has been the most consistent in having the mod find the new atty. And it does make a difference when the correct initial resistance is found and used by the mod.

1 Like

A me mi gusta tambien! Mine never asks new coil. Let me know what you figure. I can get it to work with my new build .13 24g dual coil Ti at 40 w but kanthol at 60 watts .3 in my new goblin produces flavor the other dont

@john70 try getting that coil question to pop up on yours and let me know if that changes it for you…

I feel your pain and I had a similar experience when I switched from nickel wire to titanium wire but that turned out to be a defective mod. I was ready to give up on Ti wire until my eVic VTC mini arrived and everything worked fine. The mod in question would work fine with power mode and TC mode with nickel but put a Ti build in and it went nuts. @Pro_Vapes and @SthrnMixer and others jumped in and did everything they could think of to help but I could not get it working. I now feel the pain they felt as it gets frustrating on both ends when you are trying to figure things out and nothing is working.

All I can tell you is my RX200 is working fine in Ti mode no matter what build I put in my velocity. If I put a dual coil 7wrap build on it a single coil 7wrap build I can adjust the temperature and watts and dial it in for my liking. I was up most of the night trying different builds just to see if I could make it act stupid and not once did I have any issues with it no matter what I tried.

I am beginning to believe there are a couple of defective mods here causing this problem. All I know is I am having no issues at all with my RX and to date it is the best mod I have ever had. I am getting a full day on battery life plug it in overnight and the next day same thing battery last all day and I am a chain vapor. Back when my Segelei 150 was what I used all day I would have to change batteries every evening but the RX is going all day with room to spare.

1 Like

I at 60 w with the .13 24g dual Ti I am now getting good flavor and cloud at 600 degrees the lower the temp though the sooner it kicks out

1 Like

lol the fun of diy!

1 Like

I agree with @SthrnMixer on this as he has mentioned earlier in this post to get your mod to verify that it has a new atty/tank on so it can set the base resistance for said atty/tank, otherwise it’s off from the get go.
However that sometimes is easier said than done with ss on the rx200. Once thats done you can lock your resistance in.
I’m really pleased with my rx200 as is @wvsanta but I mainly use ti also.
I’ve just attached my crown tank with the 0.25 ss stock coil and was prompted new coil/same coil. The crown coils are 304ss so i would say the update that’s due for the Rx200 will sort out the TCOR issues that i think are the sorce of the problems with ss
Ni I don’t use so can’t say on that one. But all else runs fine for me. I think its a great mod and will come into its own when fully updated.
Joyetech release updates quite often (e vic mini update today as example) and im sure all these issues will be ironed out.


600f seems high john. When its lower do you mean temp protect is kicking in?

1 Like

Yes 3 sec vape at 560, then two then o

With a 22g ti build the highest i can go is 540f then it’s too warm for me. Confusing your set up as I’m getting good results. I’ll try a 24g and get back to you john.


Been using a 24g ti duel coil 0.1 2.5id at 60w 540f no problems. Chain vaped about 10 tokes on my STEAMCRAVE rdta and nice warm vape.
Mabey just do a recheck of every thing. Let it cool down and get your mod to verify new coil and lets know how you get on. :+1:

1 Like

Sure does sound like a wicking issue to me It took me forever to adjust to wicking TI wire.

EDIT: I wick Ti very lose in comparison to kanthal

I think I solved it. It indeed comes down to that new coil/old coil question.
I tried a dual 26g 4wrap 0,15ohm build on the derringer RDA. Put the atty on, locked it, fired it…unscrew it…fired it…unlocked it…fired it…put the atty back on and as soon as i fired the question came.
Now im vaping a nice warm dense flavorfull vape on 70watts @ 200degrees Celcius. It vapes just like i expected temp control to vape. I even vaped the cotton bone dry without getting any dry hits.

I iz a very happy bunny!
Thanks for helping me out! Really appreciate it!

EDIT: i have wicked it pretty tight now since i saw in one of my many previous builds that i had a hotspot in one of the coil legs. I thought it was because the cotton was too loose and not cooling the wire enough.

1 Like

Glad another one has found a happy spot

after a wonderful vape 0,15ohm @70watts 200degrees celcius i just tried resetting everything again after atty and mod cooled down to room temp, and now i cant get it no longer to work again hahahaha
it was locked at 0.15ohm…so i fired…unscrewed…fired…unlocked…fired again…screw atty on…came in on 0.11ohm. fired an no question came. so i tried that same sequence again and again no question. third time i tried the procedure, the question came but by that time the resistancehad risen to 0.16. pressed up for new coil and locked it at 0.16ohm. At the same 70watts, 200degrees celcius, i now have a mini afterburner, instant dry hit, and when i took the cap of the derringer and fired, the coils started glowing…

temp control…more like a temperament control test :smile:
off to bed now.

1 Like

Build works fine on myIPV4S

Now you know what it is to get it right. Mabey the update thats due will got to prompt new/old a bit better. That seems to be the root of the problems. :ok_hand:

yeah that definately would be a big help. but the biggest thing would be to manual set the resistance of the coil.

im starting to think that i should have gone for the DNA version and not the RX… :frowning:

I honestly think the rx200 will come together after an update. It’s not far away and joyetech are are good with there updates. There is a one due to be released for tcor , be similar to the e vic mini update, and you should be able to dial it in. :ok_hand: