SMOK XCube II Titanium TCoR Setup Issues

I’m using mine w a single ti @.27 ohms a tcor of .000504 it would let me choose dual if I wanted to… idk? did you try to just for shits and giggles plug it into your pc and re-do the update hard wired?? just thinking out loud…

1 Like

I just had to uninstall and reinstall the app to work properly I wonder if the app needs to recognize the new mod separately??

1 Like

did that twice

I wish I knew… wtf??? I would have fkn smashed it to pieces by now!!! I’m getting pissed and its not even mine :fearful:

1 Like

The network stuff I’ve seen before… Looked like their servers were down - I let some time pass, then it worked for me…


did setting the tcor @.000500 or higher work for you?

I’ve set it from minimum to the max and nothing work.

I’ve tried every trick that I did on my first cube and nothing is working.

Maybe just a lemon ??? sucks

@Pro_Vapes if youve went through all the same steps as your previous x cube and still not working there isn’t alot else to do. Except re programming the thing, then it must be faulty. You shouldn’t have to go through that full stop. I would be requesting a refund!


I put in a ticket over the weekend. More than likely they were off. I’m waiting for a reply.


So you’re not alone here @Pro_Vapes

I just bought the TC option in the app even though TC was already activated via the mod itself and I had Ni option available to setup. I went and bought the Ti option after wasting 3 bucks for something that was already enabled. Now I do not get the option via the mod itself to change to Ti, it still only lets me see Ni via the mod. On the app however, I can setup a Ti coil…

I just upgraded to this myself. I am now having the same exact issues as @Pro_Vapes is having.

My mod says short atomizer and the app says check atomizer. I just took this off of my vtc mini as it was vaping beautifully.

I went into the app, put Ti coil on, and it will not push it to the mod itself… This is so bogus.

1 Like

Did you ever sort out why it says short atomizer? It is doing this with all my Ti coils. I cannot even fire a tank on this mod…

Dang it PV - I was hoping you were going to show up on here and say you had found the problem and all is good. I really hate you’re having this problem.

I see they have released Firmware v1.093 yesterday. Maybe that might fix you? It’s also supposed to move it up to 180 watts.

@ryan8five0 I have found the xCube sometimes is far more sensitive than the eVic. When I’ve had this problem I usually try to find where I may have a less than tight coil lead and check all connections. If I still don’t get results I will rebuild. But then again I suspect as others there are bad chips on some of these and I got lucky not getting one.

I thought why just tell you about the new update. I’ll be the guinea pig. So I just did the firmware update to 1.093. I had to go in to the app and upgrade TI and SS again, but I wasn’t charged for it. So at least with my app signed in it remembered my previous purchase. Everything seems to be working. I will report any anomalies here.

Edit - If you have any problems getting the update just send me a PM with your email and I’ll zip it up and send to you. Offer stands for anyone who may need.


I am running an SC Ti build v1.092 and my conditions of operation are exactly as @Jimmer has stated 1-5 above.

HOWEVER, I think changing the resistance manually is a mistake, at least it never worked right for me. I understood that it was just to offset if your cube wasn’t measuring the proper cold resistance. I have to remove the atty, fire, and reinstall cold. It measures exactly the same as my Drok resistance meter so long as it’s cold. Not being able to say “no” to “is this a new coil” is frustrating enough.

Im virtually certain this is all software…I dunno, maybe reading the wrong resistance is hardware, but it’s a pretty crappy situation. The tank and coils are the bees friggin knees, but the mod is far too complicated and nickel and diming us on wire choice is just asking for a competitor to do better. The app is a stupid complication that serves no purpose to the user, but id bet you my left nut THEY’RE getting lots of useful information about us from it, maybe I should look at the apps permissions on my phone too, huh? These people seem retarded or they have no idea how to market a product. I like the mods power, the trigger…all the mechanics.

Even when TC is working correctly you get these slow pulses of on/off. This is my first TC mod, but as an engineer I know they should be able to smooth that whack slow pulsing out to where the user doesn’t notice. Further proof to me that R&D in China hasn’t come far from the “receive and duplicate” model it was 10 or more years ago. Harsh generalization of a giant country, but I have many other more direct experiences.

SMOK, GET YOUR CODE MONKEYS IN-LINE AND FIX ACTUAL PROBLEMS. I haven’t seen a single complaint that it’s “only” 160W . We don’t care how cool it looks if it doesn’t work and if you think you’re building a brand people will follow, it’s only going to be with pitchforks and torches until you fix this stuff!

Fix these:

  1. is this a new coil, “no” should work

  2. kill the app, it’s costing you customers

  3. enable all wires from the beginning, you don’t need whatever you are getting from my phone that badly.

  4. make TC work faster than I can by just modulating the button in power mode.

  5. ping the coil resistance every few seconds while awake so you can detect when I remove the tank and ask automatically on reinstall.

  6. If you don’t kill the app, don’t make me use it again to switch back to Ti after hitting Ni

  7. Provide a shortcut to turn it off
    8)switch the + & - buttons when the screen is flipped for the love of God

  8. ladies and gentlen, Pease enumerate the problems I have missed.

nice work on the lights and stuff, on the cube 3 try focusing on the vaping part of the mod.


Man …after about 6 hours of friggin around with this thing I finally got it working good . I had to increase the res on the coil by .03 then raise the tcor to .004 and now I can maintain a good vape at 450f. I wish I wouldn’t have upgraded the titanium as the lowest tcor setting for the nickel was .004 ! Could have saved myself a cool half buck! I wasn’t able to upgrade the software either and as of now don’t really care .

1 Like

I keep hearing this talk about “pulsing” in TC mode. If you have the temp set at 450F, it’s going to hit that temp pretty quick. Once that temp is hit, it’s going to pop the TC protection and won’t fire again until the coil is below 450F. If you hold the trigger down, the “pulse” as you call it, is just visual, you shouldn’t notice it in your vape unless you let up on the trigger. It’s kind of like your oven. If you set it to 450*F, once that temp is hit, the oven doesn’t keep the fire going, it shuts off and on dependent of the temp.

1 Like

You’re right it hits temperature quickly - especially with smaller gauge coils. And you’re right that once it hits the set temp it will go into temp protection. And you’re right (in my view of the world) that you shouldn’t notice it. But as many xCube II owners will tell you, too often you do notice it. Again, especially true with smaller gauge coils. When I have 22ga Ti coils installed the ramp up time is considerably slower, but the pulsing on/off is far reduced. However, I can built a 26ga dual coil and it will pulse like a strobe light.

1 Like