SMOK XCube II Titanium TCoR Setup Issues

TCoR should be good at default setting - if it doesn’t act as expected, try setting the ohms manually - mine doesn’t detect resistance with enough precision - if I adjust the ohms, it works perfectly for me :smile:

1 Like

Ive found the ohm’s can be off by .1-.2 so this could be the problem. Thanks guys.

1 Like

@Pattie most definitely does thank you! What settings would you recommend? I’ve heard that it can be complicated but once you get it going it’s one of the best

1 Like

@mattyice1 try reading from the top of this page or search smok x cube review and have a read. :+1:

1 Like

The ios update is available. You can adjust TCoR in the app now.

1 Like

I’m troubleshooting my new XCube2 because I can’t get it to vape using a dual Ti coil build @ .086 ohm. BTW I’m vaping this same tank on my other XCube2.

I put together a series of picture to show how I’m setting my new XCube2 v1.092.

If I’m doing something wrong please inform me.

Temp Mode Setting

Vape Setting

Wire Type - My only option is Nickel. Do you have another option here?

TCoR Setting. No Ti Option Available

Manual Coil Ohm Setting

Number of Coils

So none of this works because I can’t program it for Ti. So I program from the App. Once it’s programmed I click the check mark in the top right hand corner.

This is what I get when I hit the fire button. I take the same tank and put it on my other XCube2 and vape away.

I’m on my third day and I still can only use this mod in VW Mode.

If anyone is having success with the v1.092 using dual Ti coils please let me know how you are setting it up.

I contacted Smok for support and Efun for a return for a refund and I haven’t got a reply.

Could be a fault unit?!

I have a feeling it’s in the software. Even though I set it on the App, the mod doesn’t recognize my settings. My only option on the mod is Nickel.

Man! I feel your frustration. I am running a dual Ti build on my velocity. Here are the steps I have to go through:

  1. Check resistance on Ohm meter
  2. I have to fire the Cube with no atty on it and get the “check atomizer” message. This seems to reset it; and it is the only way I can reliably have it give me the “new coil?” message. To which I say Y.
  3. Turn on bluetooth
  4. Open app, select Titanium in settings, then the checkmark in the upper right hand corner. (If I was in nickel mode previously on the mod it WILL NOT let me change it to Ti on the mod itself - I HAVE to use the app.)
  5. Go to settings, and titanium should be selected. (don’t try to toggle it between Ni and Ti, it won’t revert back to Ti from Ni unless you go through the app again). l then go into settings, Mode, Temp, Ti, I leave the TCoR at the default(.00350), and DC for dual coil.
  6. Go into settings and set the resistance manually to the resistance you found on your Ohm meter.
  7. Adjust the temperature until you get a satisfying vape. (for me this is between 450 - 550, with a preferred ‘sweet spot’ of 480 degrees.)

There are probably different ways of achieving the same thing, but these are the steps I use and I haven’t had any problem with any of my 3 RDAs that have Ti builds.

I hope this helps,


1 Like

[quote=“Pro_Vapes, post:46, topic:27865”]
Wire Type - My only option is Nickel. Do you have another option here?

TCoR Setting. No Ti Option Available
[/quote]There is no option for Ti in the menu on the mod. They sent me a mod with no Ti Support.

You are right. After you use the app to select Titanium from the bottom ‘bar’ and select Confirm and then the checkmark, the bluetooth sets the wire type to Ti.

Using the app is the only way I can get it to switch to Ti. Like you when I try to switch from Ni to Ti on the mod it does not give me the Ti option and it won’t switch from Ni.

1 Like

I’m gonna try some different tanks. Thanks @Jimmer

Let me know how it goes. Best of luck.

1 Like

Looks like the settings hasn’t transferred from the app to your mod… I run 1.092 - When I choose temp mode, I get:




Try going to the app, and select Up-gradation…

Oh, and my dual coil Ti-build works beautifully on it, if I just change the ohms a bit…

1 Like

I’ll try it again Thanks.

I get this on 2 tablets and my old phone

I get this when I try to log in. I know my password is correct because I used it a couple days ago and saved it. I’m not able to reset my password either. This whole situation is whack. Smoke has people jumping through hoops just to get a Vape. They put you through all this BS just to get an extra dollar out of you. This is nonsense. I’m done with this mod. If anybody want to buy a brand new BLACK SMOK XCUBE2, I have one for $40.

Since ive updated the app it wont let me sing in.

Try this. Turn off or take the batteries out of your other Smok mods. Then connect the new one. Perhaps give it a unique name through the app. Once you’re connected to that new mod recheck that upgradation is complete. Then set up your settings. I’m just thinking it may be an app issue. Also if there is a way to forget the other devices so you are only connected to the new one maybe that’s worth a try.

It’s all BS. I thought Smok had improved there shit, but obviously not. This thing is no better than the M80. Half are good and half are bad. A fuckin headache to use. I waited to buy this to see how the upgrade will be. Not only is the fucked up… the fuckin app is to. They should at least offer a downgrade. I’d love to have the v1.080 if I could find it. I can’t get my old copy to work. It says something about missing data.

Good idea, but it won’t work either. I even tried register a new account and I even do that.

Sorry to hear your having problems mate, its so frustrating, hope you find a solution soon.

1 Like