Stainless Steel TC - X Cube 2

Well the latest version of the X Cube 2’s firmware supports stainless steel temp control. Haven’t tried it yet. I think I’m gonna let someone else try first.

Sorry if this has been posted already.


Wow, cool! 1.09 - I’m gonna update it and test it soon :smiley:

Is this yet another thing you have to activate in the app?

Cool indeed. Says just to enable stainless steel coil in the app. The app does not reference stainless steel TC at all… the app hasn’t been updated in about a week anyway, so I imagine there will be an update soon.

On the mod itself, I do not see SS as a choice for TC. I’ve confirmed 1.09 is what I’m running. Sounds like we need more info from Smok. We’ll get it sooner or later in all it’s broken English glory.

Funny thing is when I select SS as coil type in the app, it says it’s not unlocked. Well… not funny, but you know what I mean.

I just upgraded - No SS activation - In the app settings I see “Stainless Steel Coil” at the bottom - clicking it, lets you choose Ni200, Ti and SS - Clicking it says “Not unlock” :confused:

I think that the only thing SS-coil does is set the temperature coefficient to 0.00075…

Me too… the only coil type I can select in the app is Ni200. The others say they’re unlocked…err locked I mean.

The only coil type avail to select in the mod is Nickel. What about you Daath?

If you bought Ti-wire support, go to “Vapor Up-gradation” and press “Upgrade” on Titanium - it should say “Upgradation successful” or something to that effect. That way you can use it again.

It looks like SS is disabled until they release a new “Vapor up-gradation” :smiley:

Thanks. Ti can now be selected.

I know this is for another topic altogether, but like I said I can enable TI in the app, but I don’t have TI as an option in the mod. Is all the mod/app doing when you change coil type is updating the coefficiency? If so, all I would have to do is select Nickel and use the coefficiency for TI, right?

No, unfortunately I think they made it so that Ni coefficiency is standard coefficients +/- a little - and that little doesn’t go all the way to titanium range. I thought I could do that with SS, but you can’t adjust coefficiency that low.

I think they may have borked the 1.09 - I only have TC-NI as well - before, I had TC-TI on the mod…

Me too. I did have more than NI before the update. Surprised? I’m not.

BTW did you use the new update tool? I did, but it didn’t change the fw to 1.09, even though the 1.09 fw was in the new updater’s folder.

I used the new beta updater, yes - it did update mine…

Interesting. I do like it though. Way faster and easier.

1 Like

Well Daath, the reason why we get the error about stainless steel is because we need to BUY stainless steel. This one costs 99 cents. I’m gonna pass. Smok must think the Call of Duty sales model should apply to vaporizers.

Edit: What they added in 1.091 is SS in the coil settings of the mod itself. Apparently buying SS support is already supposed to be there in the app, but I don’t see it.

I haven’t upgraded because my batteries are dead so I can’t confirm if SS is actually available. I read from one fellow that he needed to enable SS in the app and when he saved it, it changed the TCF to what it should be for SS. He did this because SS still wasn’t available in the mod itself.

I just checked again in the app - now I get a network error :stuck_out_tongue:

Well… time to fix your network. I highly doubt it’s on smok’s end.

1 Like

Sorry if this was already mentioned but I didn’t read through the whole post you have to actually buy the stainless steel option which is ridiculous in my eyes but I guess that’s what you get for a cheap mod is they get you on the little things. Supposedly all the stuff disappears but reappears when you go and reactivate it I haven’t tried this yet but if you look in the app under their forum you’ll see a lot of answers
I dont use the app but my mod shows Ti dual coil or single, does yours not show this @ffrank?

Yeah my mod just shows TI single and dual. I’ve got 1.09 not 1.091 though because my batteries died before it was released. You have 1.091? That supposedly will let you toggle through all coil types you have unlocked.